Authentication is now required to suspend; how do I disable this?

asked 2015-10-15 21:43:25 -0500

njackson gravatar image

Suddenly I'm being asked for authentication before Fedora will let me suspend my system. I'm not sure where this new behaviour came from, but I need to turn it off. How would I go about doing so? I am on Fedora 21, kernel 4.1.8-100.fc21.x86_64.

Previously (for the past two years) when I closed the lid of my laptop, or used the suspend key on the keyboard, my system would go immediately into suspend. Since about two days ago, I get a dialog bos saying "Authentication is required for suspending the system" and a prompt for a password, and only after entering the password does the system suspend.

It makes sense to me to enter my password to unlock my system after suspend, but is seems absurd to have to enter a password to go in to suspend. I need to be able to make my system suspend at a moment's notice; I don't have time for entering passwords.

I'm not sure what might have caused this new behaviour. I don't think there were system updates. The only change I made was that I installed and tried out the Cinnamon desktop. I observed this problem in Cinnamon the first time I tried to suspend -- so I initially though it was a Cinnamon problem. But the problem is also occurring in GNOME.

I had a look at the Fedora 21 System Administrator's Guide but I couldn't find anything about permissions for anything other than file access. I'm guessing there must be security settings somewhere that say which type of user can do various things on the system, but I'm not sure how to go about discovering them.

edit retag flag offensive close merge delete

Comments

Your question aside, you should consider upgrading to a supported release of Fedora (22/23). Fedora 21 has reached End-of-Life, and will not receive important security updates anymore..

florian gravatar imageflorian ( 2016-01-19 10:45:57 -0500 )edit