Ask Your Question
0

unable to disable discrete ATI Graphics Card

asked 2015-10-01 19:56:40 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Hi,

I am withing this as a last resort, hope you guys can help me.

My HP laptop came with Dual graphics:

[ashesh@MISTRI ~] $ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7500M/7600M Series] (rev ff)

Power setting

[root@MISTRI ashesh] $ cat /sys/kernel/debug/vgaswitcheroo/switch
0:IGD:+:Pwr:0000:00:02.0
1:DIS: :DynOff:0000:01:00.0

Going through various blogs I tried turning the ATI Card off

[root@MISTRI ashesh] $ echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

However, that didn't make any change to the cat /sys/kernel/debug/vgaswitcheroo/switch output and the ATI card still seems to be active. the laptop gets really uncomfortable for use after a short while.

Please help.

edit retag flag offensive close merge delete

Comments

Yeah, looks like yolo is correct below - your ATI card is not being reported as powered on. When you say "the laptop gets really uncomfortable for use after a short while", I assume you're talking about heat emission? If so, are you simply assuming the heat emission problem is the result of your graphics card? You might try installing lm_sensors to see if you can get some more insight into the source of the heat. It may not be that little GPU at all.

bitwiseoperator gravatar imagebitwiseoperator ( 2015-10-02 16:23:57 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-10-02 11:13:21 -0500

updated 2015-10-02 12:14:18 -0500

From the cat /sys/kernel/debug/vgaswitcheroo/switch output, your integrated card (IGD) is active ('+' in the third column). The IGD is usually you Intel card. That means your Intel card is active and not your Radeon one (DIScret).

Now, to switch to your discret card (Radeon) :

Turn on the GPU that is not currently active :

echo ON > /sys/kernel/debug/vgaswitcheroo/switch

Connect to the discrete card:

echo DIS > /sys/kernel/debug/vgaswitcheroo/switch

Prepare a switch to the discrete card (Xorg has to be restarted):

echo DDIS > /sys/kernel/debug/vgaswitcheroo/switch

Then log off and reconnect to your session. You can test this in order to check if your graphic behaviour becomes better. Also, you may find a fix for you Intel card.

To switch back to the integrated card (Intel), use the same commands with ON, IGD and DIGD keywords.

If any issue : Ctl+Alt+F3 to open a console and check the log sudo tail -n 100 /var/log/Xorg.0.log

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-10-01 19:56:40 -0500

Seen: 1,622 times

Last updated: Oct 02 '15