Ask Your Question
0

Unwanted laptop sleep

asked 2015-09-30 01:00:11 -0500

spysiuk gravatar image

updated 2015-10-01 14:14:51 -0500

Hi, I'm new to Fedora so I'm not sure if this is Fedora issue - maybe it has to do something with Gnome but I never experienced this behavior on other distros. The problem is that I can't prevent my computer (Sony VAIO ultrabook) from going to sleep - if I start a computer and don't logon it is is going to sleep after some time. If I logon the computer is awake all the time (I had to completely turn off power management in Gnome) but If I press lock button the lock screen is showed for a moment and computer goes to sleep immediately. Am I missing something? Can anyone help me?

I think this is not configuration problem. After lock-suspend-resume I get an error report for xorg-x11-drv-intel. The report says that this bug is already in bugzilla (id 1206922).

sergiomb, lsatenstein thanks for your help :-)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-09-30 09:51:08 -0500

sergiomb gravatar image

Hi, You, also, may configure all settings with systemd , systemd have systemd-logind.service , you may configure lid behaviour, power button and suspend key etc , I don't know if it helps ...

cd /etc/systemd/

grep -iP "suspend|lid" *
logind.conf:#HandleSuspendKey=suspend
logind.conf:#HandleLidSwitch=suspend
logind.conf:#HandleLidSwitchDocked=ignore
logind.conf:#SuspendKeyIgnoreInhibited=no
logind.conf:#LidSwitchIgnoreInhibited=yes
edit flag offensive delete link more
1

answered 2015-09-30 06:07:47 -0500

lsatenstein gravatar image

At the top right corner, click on the bottom left most icon (system) In that display of various settings, click on Power. Fix up that setting to please yourself.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2015-09-30 01:00:11 -0500

Seen: 230 times

Last updated: Oct 01 '15