Ask Your Question
0

How to use Ctrl+Shift in parallel (Fedora22)

asked 2015-09-29 16:38:50 -0500

thrashzone_ua gravatar image

In my system (Fedora 22, GNOME 3) I use Ctrl+Shift to change language. At the same in browser I can't move back on tabs (Ctrl + Shit + Tab), I'm just moving forward and the language changes. For example if I use Alt + Shift to change language, in browser everything is fine with Ctrl + Shift + Tab. What I have to do in order to user Ctrl + Shift ?

edit retag flag offensive close merge delete

Comments

Ctrl+Shift are two modifiers and thus should not be used as shortcut by itself.

Why don't you stick to Super + Space to change keyboard layout?

Your question has been covered several times on this site, here, here, here, and ...

florian gravatar imageflorian ( 2015-09-29 18:06:19 -0500 )edit

Can I change this schema with two modifiers? I know many ways how to specify my custom shortcut for changing language but I don't now how resolve conflict with another shortcuts that use Ctrl + Shift. What can I do to solve this conflict?

thrashzone_ua gravatar imagethrashzone_ua ( 2015-09-30 03:23:08 -0500 )edit

I don't see any solution to solve this conflict. A shortcut can be used only once. As far as I know CTRL + SHIFT by itself is not a valid shortcut combination. But if you get it to work, you could disable the Firefox shortcut for CRTL+SHIFT+TAB. Not sure anymore, if I am understanding your question correctly.

florian gravatar imageflorian ( 2015-10-01 12:29:34 -0500 )edit

Thank you for your attention. I tried to do it via standard option menu, then with gnome tweak tools, then with gconf. No result.

thrashzone_ua gravatar imagethrashzone_ua ( 2015-10-04 01:22:03 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2015-09-29 17:02:02 -0500

msx gravatar image

Hi, You can adjust the keyboard shortcuts to your needs in Settings -> Keyboard -> Shortcuts. HTH

edit flag offensive delete link more

Comments

I know how to specify custom shortcuts. I don't know how to resolve conflict between custom shortcuts and existing one, for example between Ctrl + Shift as language switcher and Ctrl + Shift + Tab (allows to go to previous tab in browser). I had the same problem on Debian 8 (also with GNOME3, if it's important), but in Ubuntu, Mint, Windows there wasn't any such problems.

thrashzone_ua gravatar imagethrashzone_ua ( 2015-09-30 01:22:19 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-09-29 16:38:50 -0500

Seen: 324 times

Last updated: Sep 29 '15