Ask Your Question
0

Xen crashes on boot

asked 2011-11-30 11:52:14 -0500

taiss gravatar image

I've not been able to get Xen 4.1.2 to boot on Fedora 16. 64-bit kernel 3.1.2 boots on bare metal from Grub2 on a GPT-labeled disk, but Xen 4.1.2 crashes immediately after loading the initrd and reboots.

The reboot happens too quickly to see any screen error messages, but I wonder if I'm hitting this problem: http://wiki.xen.org/xenwiki/XenCommonProblems.html#head-d038e27f4f3ad6b96ef1643c1812237cb1408730.

From what I can see, grub2 is a 32-bit package even on 64-bit, and the Xen hypervisor is also a 32-bit package even on 64-bit. It appears that grub2 is loading the dom0 kernel in an address the hypervisor can't reach, since I have 8GB RAM installed.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2011-11-30 12:56:17 -0500

Insufficient information.

What kernel are you trying to boot ? Did you compile a kernel yourself ?

Rather then guessing at the problem, please post the relevant error message.

See also : https://fedoraproject.org/wiki/Commonkernelproblems

edit flag offensive delete link more
0

answered 2011-11-30 13:10:04 -0500

Can you check the logs then ? Shut it off when it reboots, boot a live CD, and check

/var/log/boot and /var/log/messages

Also check the kernel debugging page I gave you.

edit flag offensive delete link more

Comments

From "gzip -dc /boot/xen-4.1.2.gz | file - yields: ELF 32-bit LSB" and "I installed the x86_64 arch for xen-hypervisor" are you trying to boot a 32 bit kernel on an otherwise 64 bit OS ?

bodhi.zazen gravatar imagebodhi.zazen ( 2011-12-03 19:14:47 -0500 )edit

It appears that way.

bodhi.zazen gravatar imagebodhi.zazen ( 2011-12-04 09:16:53 -0500 )edit

Question Tools

Stats

Asked: 2011-11-30 11:52:14 -0500

Seen: 1,207 times

Last updated: Nov 30 '11