Ask Your Question
1

Date not updated after waking up

asked 2015-09-24 15:26:49 -0500

Each time I wake my laptop up from suspended mode, the date is not updated and continues from the time that it was on when it went to sleep.

I think I have seen it update it self to the correct time, but I'm not sure what trickers it. I might be mistaken tough, at the moment I'm writing this the system has not updated the date to the correct date and time for about 5 hours.

I don't seem to find discussion on this issue anywhere, might be that I mostly don't know how to word the problem to get the search results I want, mostly just find completely unrelated issues.

Anybody have any ideas what could cause this and how to fix it? I did run a UbuntuGnome and Linux Mint on the machine before I tried out Fedora recently but this had not been a issue on those systems.

I use "date" in the Terminal to check the system date.

The only fix I have at the moment is to restart the machine, logging out is not enough.

edit retag flag offensive close merge delete

Comments

Does the output of timedatectl status look right to you? By default, Fedora 22 implements chronyd as a systemd service. You can manipulate it through the timedatectl command. If you call the status option, you should see output that indicates "NTP enabled: yes" and "NTP synchronized: yes"; time data presented should be correct, as well. You can check on the status of the chronyd.service with systemctl status chronyd.service. It should be running and the log entries should show that chronyd successfully selected a source and made some modification(s) to your system clock recently.

bitwiseoperator gravatar imagebitwiseoperator ( 2015-09-24 22:14:23 -0500 )edit

If everything looks good, wait until the issue occurs again and use timedatectl status and systemctl status chronyd.service to see what the relevant subsystems are doing while the issue is going on.

bitwiseoperator gravatar imagebitwiseoperator ( 2015-09-24 22:16:12 -0500 )edit

Thank you for your response. The timedatectl status returns the same incorrect time as date. It says that NTP is enabled but "NTP synchronized: no". The systemctl status chronyd.service does say it found a source but says also that the system clock is wrong. You can see a screenshot of it here

Einar Ólafsson gravatar imageEinar Ólafsson ( 2015-09-28 16:06:26 -0500 )edit

Ah ha, now we're on to it; can you execute chronyc sources and post the output? There's probably some sort of problem with your connection to the default NTP servers used with Fedora.

bitwiseoperator gravatar imagebitwiseoperator ( 2015-09-28 16:28:19 -0500 )edit

here is a screenshot from the chronyc sources output. Note I'm located in Iceland, vedur.is is the Icelandic Meteorological Office and isnic.is is the .is Domain registry. This is nothing I have set up my self though, not directly at least.

Einar Ólafsson gravatar imageEinar Ólafsson ( 2015-09-28 16:47:11 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-04-24 13:26:48 -0500

This happens to me in: Fedora 27 Ubuntu 16.04 Mint 18 Debin 9

Also in Oracle VM VirtualBox Manager for the above OSes.

The only solution is to either restart the system or guest OS in the case of VM working;

use the date to command to reset date and time to a "close enough" setting.

Any hopes of getting a real fix?

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-09-24 15:23:39 -0500

Seen: 562 times

Last updated: Sep 24 '15