Ask Your Question
1

fedup remains in Grub after upgrade

asked 2015-09-20 05:03:50 -0500

oliverg gravatar image

I recently had problems with my graphics driver in Fedora 21 (see Distorted image) and thought I might resolve it by upgrading to Fedora 22. I then removed the nvidia driver as per rpmfusion guide:

sudo yum remove xorg-x11-drv-nvidia\*

I updated my system, started fedup, got a warning regarding the biber package. Then I aborted the upgrade, removed biber, started fedup again and rebooted:

sudo fedup --network 22
sudo fedup --resetbootloader
sudo yum remove biber
sudo fedup --network 22
reboot

The upgrade was an access, I did all the post-upgrade steps documented in the (fedup wiki)[https://fedoraproject.org/wiki/FedUp#Cleaning_Up_Post_Upgrade]

sudo rpm --rebuilddb
sudo dnf distro-sync --setopt=deltarpm=0
sudo dnf install rpmconf
sudo rpmconf -a

I replaced all the configuration files found by rpmconf with the repo versions. Then I rebooted again and installed the nvidia driver:

sudo dnf install akmod-nvidia

The reboot wasn't as successful as I hoped, I got the "Oops, something went wrong" screen. I switched to terminal and forced kmod compilation:

akmods --force

The result was a complaint about missing kernel-devel package, strangely the required version was 4.0.4. I checked whether I was missing the package for the current kernel (4.1.6) to no avail. I then installed the 4.0.4 kernel-devel using the command from rpmfusion:

dnf install "kernel-devel-uname-r == $(uname -r)"

kmod compilation didn't quite work yet, so I rebooted and that worked. But somehow grub has now an entry for fedup again (Fedora (fedup) 22 (Twenty Two)). After login I tried to run

sudo fedup --resetbootloader

but got a complaint that fedup is replaced by dnf system-upgrade, --resetbootloader isn't used anymore and that is ignored while redirecting fedup to dnf.

Long story short, how do I remove the fedup entry from grub? I already tried

sudo dnf system-upgrade clean
sudo dnf system-upgrade --distro-sync clean

and googled, but couldn't find any information on what replaced

fedup --resetbootloader
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-10-28 18:23:56 -0500

patrickz gravatar image

grub2-mkconfig is responsible for the grub menu generation. According to the fedora wiki it does that

on base of the currently running system, what is found in /boot, what is set in /etc/default/grub, and the customizable scripts in /etc/grub.d/.

I had a vmlinuz-fedup file in _/boot_. Thus I removed that file and ran grup2-mkconfig. That fixed it:

mv /boot/vmlinuz-fedup ~
grub2-mkconfig -o /boot/grub2/grub.cfg
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-09-20 05:03:50 -0500

Seen: 595 times

Last updated: Sep 20 '15