Ask Your Question
0

[F21] Squeezed display after updating/installing Nvidia driver

asked 2015-09-17 13:00:26 -0500

oliverg gravatar image

updated 2015-09-20 05:11:02 -0500

Edit 2: Instead of fixing the problem in Fedora 21 I upgraded to 22 and re-installed the driver. Currently, this seems to work. Thanks to everyone. I'll upvote once I've got enough karma.

After a kernel update required a update to my graphics driver (akmod-nvidia through rpmfusion) my display is squeezed horizontally. The squeezing happens for most resolutions, even the native one (1680x1050). The only resolution I found, that is working, is 1440x900. Removing the display driver lets me use the full screen with native resolution again. Re-installing the driver doesn't help.

I looked through the nvidia settings but didn't find anything useful.

Window manager is Gnome, graphics card a GTX 770. Under Windows everything works fine.

Kernel version: 4.1.6-100
Driver version: 355.11-1

Any ideas what could have gone wrong or how to restore the native resolution with the Nvidia driver?

journalctl -b _COMM=Xorg.bin (logfile)
xconfig
nvidia-bug-report.log.gz
Squeezed display

Edit: The update, that resulted in the squeezed display modified following packages

Packages Altered:
Updated akmod-nvidia-1:352.30-2.fc21.x86_64                @rpmfusion-nonfree-updates
Update               1:355.11-1.fc21.x86_64                @rpmfusion-nonfree-updates
Updated wxBase3-3.0.2-8.fc21.x86_64                        @updates
Update          3.0.2-9.fc21.x86_64                        @updates
Updated wxGTK3-3.0.2-8.fc21.x86_64                         @updates
Update         3.0.2-9.fc21.x86_64                         @updates
Updated xorg-x11-drv-nvidia-1:352.30-1.fc21.x86_64         @rpmfusion-nonfree-updates
Update                      1:355.11-1.fc21.x86_64         @rpmfusion-nonfree-updates
Updated xorg-x11-drv-nvidia-cuda-1:352.30-1.fc21.x86_64    @rpmfusion-nonfree-updates
Update                           1:355.11-1.fc21.x86_64    @rpmfusion-nonfree-updates
Updated xorg-x11-drv-nvidia-kmodsrc-1:352.30-1.fc21.x86_64 @rpmfusion-nonfree-updates
Update                              1:355.11-1.fc21.x86_64 @rpmfusion-nonfree-updates
Updated xorg-x11-drv-nvidia-libs-1:352.30-1.fc21.x86_64    @rpmfusion-nonfree-updates
Update                           1:355.11-1.fc21.x86_64    @rpmfusion-nonfree-updates
Scriptlet output:
1 /sbin/ldconfig: /usr/lib64/nvidia/libEGL.so.1 is not a symbolic link
2 
3 /sbin/ldconfig: /usr/lib64/nvidia/libEGL.so.1 is not a symbolic link
4 
5 /sbin/ldconfig: /usr/lib64/nvidia/libEGL.so.1 is not a symbolic link
6 
7 /sbin/ldconfig: /usr/lib64/nvidia/libEGL.so.1 is not a symbolic link
8 
9 /sbin/ldconfig: /usr/lib64/nvidia/libEGL.so.1 is not a symbolic link
10 
11 /sbin/ldconfig: /usr/lib64/nvidia/libEGL.so.1 is not a symbolic link
12
edit retag flag offensive close merge delete

Comments

Post some proper info if you expect help!

https://devtalk.nvidia.com/default/to...

geforce gravatar imagegeforce ( 2015-09-18 02:04:10 -0500 )edit

@leigh123linux: I've added the output from the bugreport tool. Should I also start a new topic in the nvidia forums?

oliverg gravatar imageoliverg ( 2015-09-18 09:31:56 -0500 )edit

Ok use nvidia-settings to write a config file to your home directory and post it here

http://imgur.com/iQBOQ0Z

p.s If it worked with the old driver version you should post the regression to the nvidia forum.

geforce gravatar imagegeforce ( 2015-09-18 10:53:45 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-09-17 14:05:44 -0500

xmetax gravatar image

updated 2015-09-17 14:08:49 -0500

A similar issue happened to me after a past kernel update. Akmods had failed to compile for the updated kernel. Try:

CTRL + ALT + F2 to drop to terminal.

Login

Then:

su
akmods --force

Reboot

Perhaps akmods just needs to be told to check for new kernels and compile the module.

Good luck.

edit flag offensive delete link more

Comments

Tried it, I get a message 'Checking kmod exists for 4.1.6 ... [OK]'. Nothing else happens and the problem persists.

oliverg gravatar imageoliverg ( 2015-09-17 14:15:00 -0500 )edit
1

answered 2015-09-18 11:58:44 -0500

geforce gravatar image

updated 2015-09-18 12:00:39 -0500

Try editing /etc/X11/xorg.conf to

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "HP w2207"
    HorizSync       24.0 - 82.0
    VertRefresh     48.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 770"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "nvidia-auto-select +0+0; 1680x1050 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Restart X after edit

I also checked the refresh rates against the hp specs

http://support.hp.com/gb-en/document/...

edit flag offensive delete link more

Comments

I created a new, generic xorg.conf and edited the sections to match yours, rebooted and got an error ("Oops, something went wrong"). Then I used the config generated by nvidia-settings and changed the horizontal refresh rate, rebooted and got the same error. I attached the output of journalctl from directly after the error to my question.

oliverg gravatar imageoliverg ( 2015-09-19 04:33:30 -0500 )edit

Try restoring the default config

sudo cp /etc/X11/nvidia-xorg.conf /etc/X11/xorg.conf
geforce gravatar imagegeforce ( 2015-09-19 10:26:15 -0500 )edit

My nvidia-xorg.conf was quite empty so I created a new one via nvidia-xconfig and pasted your settings into it. X is then able to start without errors, but the display stays the same. I can post the file, if you want, but there a just some additional sections for input devices and server layout. An xorg.conf with monitor, device and screen settings only, produces the same results.

oliverg gravatar imageoliverg ( 2015-09-19 12:04:00 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-09-17 12:57:33 -0500

Seen: 489 times

Last updated: Sep 20 '15