Ask Your Question
1

Disabling parallel fetch in dnf, fedora 22

asked 2015-09-15 08:14:21 -0500

MikeCZ gravatar image

Hello! Im running Fedora 22 with up to dáte everything. My network connection is provided by my university. When I run

dnf update

I usually get banned for using too many connections in said network. I suppose dnf does fetch-jobs in parallel, which leads to this situation. I've read up man dnf but didn't find anything related. Please tell me.what can I do with this. Thanks,

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
4

answered 2015-09-15 10:05:21 -0500

sudo vi /etc/dnf/dnf.conf and add this line : max_parallel_downloads=1

You can find this in man dnf.conf.

max_parallel_downloads : Maximum number of simultaneous package downloads. Defaults to 3.

edit flag offensive delete link more

Comments

Thanks for answer! However, the actual reason for this behaviour turned out to be meta-mirrors, not parallel-downloads feature of dnf.

MikeCZ gravatar imageMikeCZ ( 2015-09-16 08:53:04 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-09-15 08:14:21 -0500

Seen: 894 times

Last updated: Sep 15 '15