Ask Your Question
0

Browser Problems on Fedora 21 [closed]

asked 2015-09-10 10:27:20 -0500

edwardc01 gravatar image

Since Sept 4th I have been unable to load the www.vetfriends.com website from either Firefox (40.0.3) or from Chrome (45.0.2454.85 (64-bit)). I consistently get a blank page with the text "VetFriends.com down for maintenance. Will return in a few minutes. Thank you.". I initially reported this the the VetFriends company IT department which indicated that they couldn't duplicate the problem and had had no other reports of site problems. They indicated that the site was indeed working as they were taking orders.

I receive emails from them which contain links to the website. All these links return the above text, however if I forward the email to a friends who has both Windows and Mac he can click the link and bring up their website. He can also just use URL www.vetfriends.com and get the site. I can also get to the site from my smart phone but from my fedora 21 I can't.

Prior to Sept 4th I had no problems. I have cleared all cookies and all browser history from both Chrome and Firefox with no change. I'm not having problems getting to any other websites.

I would appreciate help and direction on how to go about troubleshooting this problem.

edit retag flag offensive reopen merge delete

Closed for the following reason question is off-topic or not relevant by davidva
close date 2015-09-10 11:21:23.259592

Comments

What is the real problem? This is a specific problem of the site author. http://s27.postimg.org/w3ksdh183/off_...

davidva gravatar imagedavidva ( 2015-09-10 11:26:25 -0500 )edit

Why did you close it....

Did you even try to recreate his problem...

http://i.imgur.com/9QscReX.png?1

seems real to me. The left screen uses chrome on a windows PC I've remote desktoped into. The right is chrome on Fedora 22.

hmaarrfk gravatar imagehmaarrfk ( 2015-09-10 11:39:39 -0500 )edit
1

Yeah, I actually recreated the issue as well. I can connect to the site fine from Firefox on a Windows 8.1 system, but from Firefox on my Fedora 22 system, I receive the message he's reporting. I was in the process of troubleshooting, and I determined that Firefox in Safe Mode does nothing to help, so it's not an extension or add-on, and accessing the site using Lynx (text-only browser) from Fedora 22 does work.

Seems like we have enough information to determine something peculiar to Fedora is causing the problem, though it might ultimately come down to the site author's code.

bitwiseoperator gravatar imagebitwiseoperator ( 2015-09-10 12:44:11 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-09-10 13:09:24 -0500

segfault gravatar image

This server is blocking any user-agent that identifies as Linux. You can visit this site on linux by spoofing a windows user-agent. That is the work-around, the solution depends on the website operator. Raise the issue with them more firmly and specifically tell the operator "Linux user agents are blocked", the right person on their team can fix it.

edit flag offensive delete link more

Comments

1

I figured that was the case - how did you go about spoofing your identity as a windows user-agent, if you don't mind me asking?

bitwiseoperator gravatar imagebitwiseoperator ( 2015-09-10 15:27:41 -0500 )edit

I would like to know how to spoof a Windows users agent as well. I have passed the above information along to the company in hopes they will fix the problem but am not counting on it (I mean how many veterans, Vietnam 70-71, do we have that use Linux exclusively).

edwardc01 gravatar imageedwardc01 ( 2015-09-11 09:47:18 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-09-10 10:27:20 -0500

Seen: 250 times

Last updated: Sep 10 '15