Ask Your Question
2

Booting ignores Fedora 22. Only Windows 8 starts

asked 2015-09-09 18:54:54 -0500

XavierStuvw gravatar image

updated 2015-10-06 10:25:41 -0500

Hi all. I managed to install Fedora 22-3 on a Aspire laptop (V3 112P P2E7 aka V11 Touch) alongside the pre-existing Windows 8. Kudos to user Yolo for getting me out of previous troubles.

I chose encryption (on safety grounds) and, among the choices, mounted /boot/efi on the EFI System Partition already available from Windows. Anaconda, the GUI managing the installation, approved all the steps and declared the outcomes a success.

However, as I restart the laptop, there's no boot selection menu presenting a choice of operating system to load. Getting this to work is the aim of this post. The system rather starts Windows 8 instead.

I have read/browsed several posts on similar issues. They seem to relate to previous versions of Fedora, reverse process (Windows 8 installed on top of Fedora), BIOS/legacy systems instead of fully fledged UEFI, and so forth. I have also browsed/read information from the docs of the Fedora Project, gained some sensible insights but ended up with not seeing the wood from the trees owing to exposure to too much information. I then prefer to ask a fresh question with a context linked-up to my own experience.

Can this problem be solved with the POST Setup Utility?

Two easy guesses to tweak were

  • to disable the 'Boot > Secure Boot' section;
  • the above plus downgrading the priority order of the 'Windows Boot Manager' below the HDD.

Neither changed a thing.

Alternatively, while the Secure Boot is enabled, I could also tune some parameters of it in the menu Security and namely

  1. Erase all Secure Boot Settings
  2. Select an UEFI file trusted for executing
  3. Restoring Secure Boot to Factory Defaults

of which option 3 gives that cozy Hop-o'-My-Thumb feeling that you can actually get started from scratch.

Booting after option 1 leads to Windows 8 anyhow. Option 2 is insightful as one sees the content of the (U)EFI directory and the folders owned by each operating system. However Fedora has no less than 5 efi files:

  1. MokManager.efi
  2. gcdx64.efi
  3. grubx64.efi
  4. shim-fedora.efi
  5. shim.efi

I have tentatively added file 3 to the 'allowable database', to no avail (Windows 8 again). This occurs irrespective of whether HDD or Windows Boot Manager are at the top of the boot sequence.

Is there a better aimed choice of settings?

If I am off track with the POST Setup Utility, could someone please explain in detail how you get the boot menu up and running from a computer that slips into the 'native' Windows 8?

This extra work seems to contrast starkly with the claims that Fedora installation takes care seamlessly of the existence of prior OSs. Happy to be corrected as I missed some important detail.

Edit (answer found) The readers may skip the rest. The solution is detailed farther down in a standalone box. Reading on could provide useful context and insights about the path to the solution though.

Additional information (cross check with Ubuntu)

To isolate the problem ... (more)

edit retag flag offensive close merge delete

Comments

2

Hi Xavier, You can disable the secure boot in the Bios settings even if it is recommended to keep it enabled.

Then, have you try when booting to change the boot order (should be F12 key in your case) ? Do you have other choices than Windows ?

yolo gravatar imageyolo ( 2015-09-10 04:40:24 -0500 )edit

As mentioned I see no difference in response whether secure boot is enabled/disabled. I have added some information to the post. I can confirm that the boot order should prioritize the pen drive. After POST it invariably splashes into Windows 8. I wish I had other choices!

XavierStuvw gravatar imageXavierStuvw ( 2015-09-10 09:49:46 -0500 )edit
1

You have a couple entries referencing the shim.efi bootloader used by fedora. Use efibootmgr -n 0001 to test entry 0001 on the next boot, then efibootmgr -n 0003 to test entry 0003 on the next reboot. To change the boot order permanently, use ie efibootmgr -n 0002,0003,0000

randomuser gravatar imagerandomuser ( 2015-09-21 17:21:33 -0500 )edit

@randomuseraefibootmgr -n 0001 (Unknown Device) successfully leads to the dual-boot splash page befibootmgr -n 0003 (Fedora) ditto. c Any idea why I have two Fedora bootnums? Is this regular? Can either be removed safely? d@yolo points out that changing the boot order calls for option -o Verified through man page for efiboomgr

XavierStuvw gravatar imageXavierStuvw ( 2015-09-24 09:30:28 -0500 )edit

2 Answers

Sort by » oldest newest most voted
3

answered 2015-09-25 16:46:43 -0500

XavierStuvw gravatar image

updated 2015-09-26 04:48:51 -0500

Issue 1: no boot from USB live

The point that the laptop could not start from live USB is moot. This was a mistake of mine in interpeting the entries of the boot order. The drive corresponding to the USB had to be 'USB HHD: Generic Flash Drive' rather than 'USB FFD', unlike what I first thought.

Using USB live is important though, since you get some important information on which files are actually in charge of the booting process. Once you are on the Fedora live, go to the terminal and type

su -

efibootmgr -v

The man page for efibootmgr is here.

From the command output make a note of which file does the job for fedora. For example in my case this information was in the line

Boot0003* Fedora HD( ...lots of numbers... )File(\EFI\fedorashim.efi)

I also noted there was the near-duplicate entry (note the RC at the end):

Boot0001* Unknown Device: HD( ...lots of numbers...)File(\EFI\fedorashim.efi) RC

Anyway, keep \EFI\fedora\shim.efi in mind, or what applies to your output, for the next step (ready to reboot).

Also, you can see fedora there. Should you be tempted to add it to the boot order with efibootmgr - o <arguments>, this is not sufficient to see it in the boot manager yet (see next step).

If you rather play with efibootmgr - o <arguments> and happen to leave out one of the booting devices from the new boot order, it may well disappear from the boot manager down the line and cause inconveniences and troubles. So watch out. My own speculation is that you don't need to tweak the boot order from here at all, although I did so in my exploration of the issue.

Issue 2: boot loader persistently splashes into Windows 8

The problem can be fixed by tweaking the boot manager. In my laptop this is InsydeH2O Setup Utility Rev 5.0. The following procedure has worked out empirically. Experts please review and comment.

  • Go to the boot manager. On this Acer Aspire laptop V3 112P P2E7 (aka V11 Touch) you call up the boot loader by hitting F2 after power on .
  • Go to menu page Boot
    1. Select Secure Boot: to enabled. This will make it possible to change the security settings hereafter
  • Go to menu page Security

    1. Set a supervisor password if you have not done it yet. If memory serves me well, this is a condition to manipulate the bunch of settings under secure-boot settings in the same page. Don't forget this password!
    2. Go to Secure Boot Server: and then select Select an UEFI file as trusted for executing and hit enter. We go navigating into some portion of the file system in search of Fedora's efi file.
    3. A new window appears with the list of mounted drives. In my case HDD0 and USB0. Aim to HDD0: select it and hit enter.
    4. Another similar windows appears with <EFI> and <System>. Select EFI and hit enter.
    5. Another ...
(more)
edit flag offensive delete link more

Comments

The efibootmgr -o command should do the trick.

Unfortunately some uefi misbehave, have kind of "protection" or reset the boot order... Each Bios is different. So you did good.

An other issue can occur with Windows which can reset the boot order. A solution is described at the end of the Arch page.

yolo gravatar imageyolo ( 2015-09-26 10:24:06 -0500 )edit

Well done, glad you got it sorted out.

randomuser gravatar imagerandomuser ( 2015-09-26 10:33:48 -0500 )edit
2

answered 2015-09-10 14:50:39 -0500

POST (power-on-self-test) is a low-level test designed to pinpoint faults in a specific hardware component. So it shouldn't be relevent. https://docs.oracle.com/cd/E19269-01/...

Shim.efi is usually used because it can handle secure boot (file signed by Microsoft). Once shim is loaded by grub, grubx64.efi is launched.

Nothing in the boot choice, let's check the efi entries. Boot with these boot settings :

  • EFI enable
  • boot secure disable
  • Fast boot disable
  • Fast Startup option in Windows 8 : no matter here (disable allows to mount the Windows partition in rw from Linux).

Boot from your usb stick under Fedora.

  • If you don't user a querty keyboard, change the “input source” in the "Region & Language” settings.
  • Then open a terminal and type su - (to get root access).
  • Run efibootmgr -v to see the efi entries and the efi boot order

You should have a fedora entry. Could you post the output?

edit flag offensive delete link more

Comments

Hi yolo! a FYI the boot manager is InsydeH2O Setup Utility Rev 5.0 b There's no Fast Boot toggle that I can see c With UEFI enabled, secure boot disabled and, above all, 'USB HHD: Generic Flash Disk' on top of boot sequence, the systems splashes into Fedora Live (edited) d The only way to start Fedora Live from USB is to restart from inside Windows 8 (proved wrong) e Keyboard is qwerty f Output of efibootmgr -v added at the bottom of my post (revised).

XavierStuvw gravatar imageXavierStuvw ( 2015-09-21 13:20:46 -0500 )edit

randomuser has been faster than me ! So just 3 comments, to permanently change the boot order : efibootmbr -o 0003,0000,0003,0000,0001 (with -o, should be a misprint).

You can also check if you have the proper files (shim.efi, grubx64.efi, grub.cfg...) in place : su then ls -l /boot/efi/EFI/fedora/

If you want you can create a windows usb recovery drive before, in case of.

yolo gravatar imageyolo ( 2015-09-21 18:16:15 -0500 )edit

@yoloa Windows recovery USB created successfully bls -l /boot/efi/EFI/fedora confirms files are in place c both efibootmgr -n 0001 (Unknown Device) and efibootmgr -n 0003 (Fedora) successfully lead to the dual-boot splash page. Credits @randomuserd why two boot entries for Fedora? Can either be removed safely? e Why the boot order 0003,0000,0003,0000,0001 (repeated bootnums)?

XavierStuvw gravatar imageXavierStuvw ( 2015-09-24 09:35:52 -0500 )edit
1

You are right (For the third time I wrote my previous comment after loosing them due to the over size, so tried to be quick). So it should be for you efibootmbr -o 0003,0000,2001,2002,2003. You can change for what you want.

yolo gravatar imageyolo ( 2015-09-24 10:55:18 -0500 )edit

The changes of the boot order with su - + efibootmgr -o whatever from the USB live are not persistent. From within Fedora live, the command line does guarantee that the boot order has been changed according to specifications. But, once rebooted, the system relapses on the settings of the (UEFI boot manager)[http://www.insyde.com/products], whether it's about restarting from the USB live again or from the Windows Boot Manager. So effectively it looks like this is not the way to manipulate the boot order and let a dual-boot chooser window showing up as routine.

XavierStuvw gravatar imageXavierStuvw ( 2015-09-25 15:15:51 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2015-09-09 18:45:52 -0500

Seen: 1,890 times

Last updated: Oct 06 '15