Ask Your Question
3

Install Fedora 22 x64 in Legacy mode without UEFI

asked 2015-09-07 20:31:37 -0500

Droidge gravatar image

updated 2015-09-08 08:40:04 -0500

Hello. I've been trying to install Fedora 22 x64 on my system lately, and I've had no success, because the installer always ends up asking me to mount /boot/efi for my UEFI system. While my system does support UEFI, I do not have a GPT partitioning, and have Windows 7 installed with MBR partitioning.

"For a UEFI installation, you must include an EFI System Partition on a GPT-formatted disk, mounted at /boot/efi.", says the Installer. I do not want a UEFI installation, but want a legacy x64 installation using MBR instead. How do I not make the drive boot into UEFI mode, or install using the non-UEFI method?

Also, due to my lack of any GPT partitioning or UEFI system on the hard disk, I do not have any efi partitions to mount at /boot/efi.

Thank you for looking at my problem.

EDIT: Problem solved by deleting BOOTX64.EFI in /BOOT/EFI folder.

edit retag flag offensive close merge delete

Comments

1

This is a boot option in your system firmware. On my system, if I have a UEFI capable USB drive, I'll see two options in the popup boot menu, ie "Kingston USB" and "UEFI: Kinston USB". If you are simply putting the install media in and turning on the computer, try pressing the function keys to bring up the popup menu, or accessing the firmware setup menus to configure it appropriately.

randomuser gravatar imagerandomuser ( 2015-09-08 00:19:49 -0500 )edit
1

Thanks everyone. I forgot to mention that my BIOS was set to boot in Legacy mode, and it wasn't the BIOS.

I was using a LiveUSB, and I got it to boot into Legacy mode by going to the /EFI/BOOT folder in the root of the USB and deleting BOOTX64.EFI. The drive then ended up having no EFI support, and worked just how I wanted it to. I guess this is the same as deleting the UEFI partition on the drive, but I didn't take that risk.

Droidge gravatar imageDroidge ( 2015-09-08 08:39:14 -0500 )edit

Good workaround! FWIW, your Legacy Mode still gave you a UEFI boot, it really is not up to Fedora how it boots. Really.

randomuser gravatar imagerandomuser ( 2015-09-08 22:49:52 -0500 )edit

@Droidge: LiveUSB is an ISO file system and hence read only. How were you able to delete the BOOTX64.EFI file from that file system?

ghd gravatar imageghd ( 2016-12-04 07:37:53 -0500 )edit

This worked... Tq...

Anonomous gravatar imageAnonomous ( 2017-10-24 18:01:53 -0500 )edit

4 Answers

Sort by Β» oldest newest most voted
0

answered 2015-09-08 00:18:01 -0500

hmaarrfk gravatar image

Try disabling UEFI on your BIOS. I think it detects which mode the USB was allowed to boot in.

Maybe, you can also try deleting the UEFI partition on the USB.

edit flag offensive delete link more

Comments

Guess deleting the UEFI partition would work just fine. I did something similar, by deleting just the .EFI file inside the BOOT folder.

Droidge gravatar imageDroidge ( 2015-09-08 08:40:59 -0500 )edit
0

answered 2016-10-24 14:16:47 -0500

I also have the same problem with fedora and I have no idea what you are discussing since i was using pc, please explain in a layman language

edit flag offensive delete link more
0

answered 2017-10-24 17:59:28 -0500

This worked... Love from india😍😘😘😘😘

edit flag offensive delete link more
0

answered 2015-09-07 21:21:00 -0500

andrewddo gravatar image

which method are you using to install fedora 22x64? cd or usb? are you sure you're not booting into EFI installation mode?

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-09-07 20:31:37 -0500

Seen: 10,919 times

Last updated: Oct 24 '17