Ask Your Question
0

getting sound with ATI hdmi

asked 2011-11-16 22:49:28 -0500

fedoraboyo gravatar image

Hey guys, I've been digging the internet for a a solution to my problem, but I haven't managed to sort it out to date. My laptop uses an ATI Radeon 4570 GPU, and I can't get sound when I use the HDMI output. On top of hearing nothing when I select it as output, videos seem to run at a really fast playback (youtube, totem etc.). When I used my internal speakers' sound card everything seems to work just fine. And yeah, my HDMI output works just fine in Windows. My HDMI souncard is identified as a RV710/710 and in hw:1,3 Any help is appreciated.

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
0

answered 2013-12-11 17:11:37 -0500

sixgig gravatar image

I had to do the following in order to get radeon audio working....

sudo nano /etc/default/grub

Add the following to the GRUB_CMDLINE_LINUX variable

GRUB_CMDLINE_LINUX="radeon.modeset=1 radeon.audio=1"

Then update grub with the new config and reboot to apply changes.

sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
sudo reboot

The only annoying problem i have now is that my screen boundaries go outside of my monitor on all sides of the screen. I can't see the top,left,bottom,right outside edge of anything. It's like i'm zoomed in or the resolution is too big.

edit flag offensive delete link more
0

answered 2011-12-17 20:22:57 -0500

tonybrowning gravatar image

With the new Fedora 16 my sound was fixed through Fedora's updates after 12 days with no sound. I'm just speculating that the new package Fedora has now added allowing one's computer to become voice activated and only if activated to allow a blind person to be able to use a computer thus delaying and/or causing our sound trouble. Of which is remarkable and a great feat!!! Sometimes they just need to get the kinks out and they probably ran into trouble along the way.

edit flag offensive delete link more
0

answered 2011-11-16 23:57:23 -0500

mether gravatar image

Do consider filing a bug report.

edit flag offensive delete link more
0

answered 2011-11-27 13:06:34 -0500

try booting with radeon.audio=1 on the kernel command line.

it should work for radeon hd 3xxx and 4xxx series cards.

later cards have no support yet, and the 3/4 cards have some issues that mean we can't enable it by default.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2011-11-16 22:49:28 -0500

Seen: 3,201 times

Last updated: Dec 11 '13