Ask Your Question
0

Scanner doesn't work on Fedora (but did work on Ubuntu): Ultima Electronics Corp. Artec E+ 48U

asked 2015-09-07 08:36:09 -0500

Geoffrey De Smet gravatar image

I am using Fedora 22. I've got an old scanner Ultima Electronics Corp. Artec E+ 48U.

When I try to scan with Simple Scan , I get "Unable to connect to scanner". When I try to scan from the command line I get:

$ scanimage -L
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

On Ubuntu linux it did work, but I had to do this:

$ lsusb
  Bus 001 Device 003: ID 05d8:4003 Ultima Electronics Corp. Artec E+ 48U
$ sudo gedit /etc/sane.d/artec_eplus48u.conf
  // Uncomment this line in that file:
  device libusb:001:003

Doing that, does't fix it on Fedora. The error messages are above stay the same.

In Simple Scan, when I try to Change Scanner, I do see Scan Source "Artec E+ 48U". The scanner itself doesn't show any scan of life when I try to scan something and it fails with "unable to connect to scanner". It is connected of course, otherwise it wouldn't show up in lsusb.

edit retag flag offensive close merge delete

Comments

sudo simple-scan doesn't work either

Geoffrey De Smet gravatar imageGeoffrey De Smet ( 2015-09-21 04:04:12 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-09-25 09:07:19 -0500

Geoffrey De Smet gravatar image

Manually copy the file Artec48.usbfile (for example from the Windows driver or from an old machine on which the scanner works) to /usr/share/sane/artec_eplus48u/Artec48.usb.

The /etc/sane.d/artec_eplus48u.conf file references that file, but it doesn't exist by default. The exact path of the usb file might be slightly different.

edit flag offensive delete link more

Comments

Messing with the device usb as mentioned above isn't needed.

Geoffrey De Smet gravatar imageGeoffrey De Smet ( 2015-09-25 09:08:27 -0500 )edit
0

answered 2015-09-07 08:39:38 -0500

geforce gravatar image

Try editing /etc/sane.d/artec_eplus48u.conf to

  // Uncomment this line in that file:
  device libusb:5d8:003
edit flag offensive delete link more

Comments

If I change that conf file accordingly (removing the "device ... 001 ..." line that I added), then Simple Scan immediately states during startup "No scanners detected". This seems worse than the original line. What's the motivation to use that magic number 5d8 in your answer?

Geoffrey De Smet gravatar imageGeoffrey De Smet ( 2015-09-08 03:01:41 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-09-07 08:36:09 -0500

Seen: 629 times

Last updated: Sep 25 '15