how to get Fedora 22 dual booting with Windows 10 (64-bit)

asked 2015-09-04 18:12:05 -0500

mgte gravatar image

Greetings! Seeking advice on a dual boot machine based on the following:

Asus Z97 (BIOS Version 2401 – 4/24/2015)
i7 @ 4GHz
32GByte of memory
Samsung 840PRO 256GB SSD with Windows 10 (64-bit)

Fedora 22 is on a second, identical Samsung 840PRO 256GB SSD.

Based on the Fedora 22 Multiboot Guide, I installed the the second Samsung SSD and performed the Fedora 22 install. However, on reboot, the system started up Windows 10. I went into the BIOS and forced the boot from the Fedora drive and go the GRUB screen with Fedora, Rescue, and Windows 10. The first time through I selected Windows 10 to confirm that would work, and indeed Windows 10 started. Again going through the Asus BIOS (for some reason the BIOS does not see the Fedora drive as bootable), I selected Fedora and low and behold got the Fedora 22 login in prompt. Interestingly, the mouse cursor would not respond. I logged in with the user account I created, but the system appeared to freeze with a grey screen and the cursor sitting in the middle. Ended up having to reset the machine.

I'm not sure if the problem with logging in is related to the fact that the BIOS is not recognizing that the Fedora drive is bootable.

Some additional information: The Windows 10 SDD is on SATA port P2 and has the label /sdb The Fedora 22 SDD is on port P1 and has the label /sda

Windows 10 seems to be running just fine, the problem right now appears to be with the GRUB and the UEFI boot process, and potentially a problem with the Fedora install (freeze on login problem).

Any suggestions welcomed!



edit retag flag offensive close merge delete



On a UEFI system, you don't boot from drives, you boot operating systems. That's why the menu says "Fedora" instead of "Sansung 840...". You can use efibootmgr to change the boot order to choose Fedora first. If Fedora has booted, and doesn't work properly, you don't have a boot/bios/grub question anymore, and you should be asking a different question.

randomuser gravatar imagerandomuser ( 2015-09-05 12:46:27 -0500 )edit

Freeze-up on login appears to have been a NVIDIA default driver issue (a GeForce GTX 780 Ti). Fixed using: getting the driver here:

A helpful hint for getting into console mode is to type and "e" at the OS selection list presented by grub, then add a "3" to the end of the line containing the Linux entry being used.

Will look into efibootmgr and grub2 to see what I glean from that for my boot problem.



mgte gravatar imagemgte ( 2015-09-06 13:49:18 -0500 )edit

Please look around the site here to learn about nvidia driver installation on Fedora. The method you chose was probably the worst of the possible options.

randomuser gravatar imagerandomuser ( 2015-09-07 00:08:57 -0500 )edit