Ask Your Question
4

Gedit interface in incorrect language

asked 2015-08-30 03:47:35 -0500

przemas gravatar image

After on of the updates gedit lost in PL interface translation - now while majority of the desktop is in PL, Gedit is in ENG . Is there any way to get PL language in Gedit back?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2015-08-30 07:59:42 -0500

updated 2015-09-01 05:04:11 -0500

Gedit uses the default language configured in your account. All settings > Users > Click on the User and and the language is displayed.

If there is a mismatch, check if the Polish language file is available : ls /usr/share/locale/pl/LC_MESSAGES/gedit.mo

Edit: The last package for Fedora 21 is not embedded with languages : gedit-3.14.4-1.fc21.x86_64.rpm. It can be checked in moving through the rpm.

The previous update is fine (gedit-3.14.3-1.fc21.x86_64.rpm) and for Fedora 22, no issue (gedit-3.16.3-1.fc22.x86_64.rpm).

I suggest you to get the previous rpm from Koji, so download this version : gedit-3.14.3-1.fc21.x86_64.rpm Then do a local install or try to extract only the language files.

Note : In Gedit, only the language of the document can be changed in clicking on the "configuration" button then "Tools", the option "Set Language..." appears. image description

edit flag offensive delete link more

Comments

1

I did this and my gedit is still in ENG while the rest of the system is not (Fedora 21)

florian gravatar imageflorian ( 2015-08-30 12:43:53 -0500 )edit

same here - I've set the language in the Tools panel and still I get Gedit in English. Also tried launching it with LC_ALL=PL and it didn't help either. Rest of the system is in Polish - only gedit seems affected. No gedit.mo though - it seems that update broke gedit for me a tad (removed translations). How can I fix it? Is there a page where I could download .mo file from?

przemas gravatar imageprzemas ( 2015-09-01 03:43:23 -0500 )edit

I edited my answer to get enough space.

yolo gravatar imageyolo ( 2015-09-01 05:04:51 -0500 )edit

@yolo. Thanks for the hint with /usr/share/locale/<language>/LC_MESSAGES/gedit.mo. Looks like gedit 3.14.4 just doesn't have a German (any?) language file.

florian gravatar imageflorian ( 2015-09-01 08:55:44 -0500 )edit
1

@yolo: thank you . As I've been giving F23 beta a shot through Boxes I've taken .mo file from there and it seems to fixed the problem :) .

przemas gravatar imageprzemas ( 2015-09-01 12:35:09 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-08-30 03:47:35 -0500

Seen: 311 times

Last updated: Sep 01 '15