Ask Your Question
0

Touchpad settings are ignored (or overriden)

asked 2015-08-22 14:43:30 -0500

Lesto gravatar image

updated 2015-08-24 16:10:42 -0500

On a Lenovo T550, the TapButton settings are incorrect with Fedora 22:

lesto@localhost:~$ synclient | grep TapB
    TapButton1              = 0
    TapButton2              = 0
    TapButton3              = 0

I created a 51-synaptics.conf in /etc/X11/xorg.conf.d with the right values:

Section "InputClass"
    Identifier "touchpad catchall"
    Driver "synaptics"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    Option "TapButton1" "1"
    Option "TapButton2" "2"
    Option "TapButton3" "3"
EndSection

which are actually picked up by the wayland server at start up:

Aug 22 21:19:11 localhost.localdomain /usr/libexec/gdm-x-session[1805]: (**) Option "TapButton1" "1"
Aug 22 21:19:11 localhost.localdomain /usr/libexec/gdm-x-session[1805]: (**) Option "TapButton2" "2"
Aug 22 21:19:11 localhost.localdomain /usr/libexec/gdm-x-session[1805]: (**) Option "TapButton3" "3"

However, nothing actually changes in the session and synclient keeps reporting the same settings (0 for all three options). It seems there is something (maybe in gnome) that resets them at a later stage.

What can I do to make sure the touchpad settings take the intended values (apart from forcing them via synclient)?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-08-22 19:06:17 -0500

updated 2015-08-22 19:06:56 -0500

A couple points, and you'll have it:

  • Wayland isn't an X server, it's wayland. If you're choosing the wayland gnome session, you're going to get libinput handling your input devices. Since your logs say gdm-x-session I don't think you're getting a wayland session.

  • If you are choosing the X gnome session, and not wayland, it's still using libinput by default, not synaptics. If you want to use another input driver, make sure the appropriate packages are installed, ie xorg-x11-drv-synaptics or xorg-x11-drv-evdev, and remove xorg-x11-drv-libinput.x86_64 .

edit flag offensive delete link more

Comments

Yes, I edited the question to not refer to X. Wayland is definitely running (as I see the Xwayland process).

Lesto gravatar imageLesto ( 2015-08-24 16:12:30 -0500 )edit
0

answered 2015-08-24 16:14:54 -0500

Lesto gravatar image

updated 2015-08-24 16:15:26 -0500

I eventually found that one needs to tick Settings > Mouse & Touchpad > Tap to click.

I find it weird that such option is not set by default.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-08-22 14:43:30 -0500

Seen: 459 times

Last updated: Aug 24 '15