Ask Your Question
0

Fedora 22 - Dual boot UEFI issue

asked 2015-08-21 18:50:03 -0500

moonbeat gravatar image

Hi,

I'm trying to install fedora 22 on a new acer laptop (aspire v nitro) in parallel with windows 10. My problem is that fedora doesn't appear in the boot menu of the firmware, and I can't boot it. I've already spent quite some time to try to understand what is UEFI.

Some details:

  • During the installation, I let fedora handle the partitioning automatically
  • From the live CD, I see a fedora entry with efibootmgr. However it's not in the boot order. If I add it in the order, reboot and rerun efibootmgr, it's been removed from the order
  • In the EFI partition itself, I see both fedora and microsoft directories.

Actually I've done two installations. I think I've managed to boot the first installation only once (with a strange name in the UEFI boot menu). There was then some failure at startup which I can't detail. On the next reboot the firmware did some kind of "recovery", and ever since "windows boot loader" is the only option available.

Question: after reinstalling fedora, I noticed in EFI/fedora that some files still date from the first installation... May I delete the fedora directory from the EFI partion and try a new "clean" installation? (I'm a bit afraid to touch this without asking...)

Thanks in advance for any information helping to resolve this problem. Please let me know if any detail is missing in my description.

edit retag flag offensive close merge delete

Comments

I have the same problem and I can't solve it.

I've installed Fedora 22 on my Toshiba Satellite, dual boot UEFI with Windows 8.1, letting Fedora do the partitioning on the space previously occupied by Fedora 20 and formatted during installation process. I have tried with Secure booting on and I've set admin passoword, but still I can't see Windows in the booting choice, there's only Fedora.

Can somebody help me? Of course I wasn't expecting problems, so I didn't prepare a Windows fail safe copy.... Please :(

Dafne gravatar imageDafne ( 2015-10-28 18:12:16 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2015-08-22 06:02:46 -0500

moonbeat gravatar image

Hi again... updating from my new fedora system :-)

Sorry, about the files date in the EFI partition, this was a mistake from me... didn't pay attention to the month (February) this was actually the date of the original files copied there... Anyway, before noticing this, I've deleted the boot entry with efibootmgr -b XXXX -B, and the complete EFI/fedora directory (just to mention it didn't cause any problem but was useless...).

Finally, the problem was in the configuration of my firmware, where this entry must be added manually. To access all options:

  • Secured UEFI must be enabled (while I disabled it after first problems to check if it would help)
  • Administrator password must be defined

Then I could select the .efi file from the EFI partition. I have the entry in the menu it doesn't get deleted anymore.

edit flag offensive delete link more
0

answered 2016-08-29 15:42:42 -0500

MiKu gravatar image

I did something similar. I've found grub's .efi file (in my case it was grubx64.efi or simmilar in EFI partition) and added it to "an UEFI file as trusted for executing". Then in boot options I've moved it above Windows loader (by default it was on button, but I could reach it by spamming F12).

My laptop is Acer aspire V Nitro.

edit flag offensive delete link more
0

answered 2015-08-23 12:02:46 -0500

EllePi gravatar image

To wipe out all possible doubts, here is a comprehensive guide to reinstall Grub and recreate the firmware boot entry: link text

edit flag offensive delete link more

Question Tools

Stats

Asked: 2015-08-21 18:50:03 -0500

Seen: 1,284 times

Last updated: Aug 23 '15