Ask Your Question

dual boot fedora 22 with windows 8.1

asked 2015-08-19 13:00:13 -0500

Belander21 gravatar image

updated 2015-10-10 15:43:41 -0500

mether gravatar image

I did all the steps to installing fedora 22 workstation to a USB drive it starts booting then stops at the icon before loading the installation setup. I tried starting with basic graphics and it gave me an error of Dracut : fatal : failed to mount block of live image. i only get this error when starting fedora this way. I already downloaded fedora 22 server and realized it was not the version i wanted because i could not load a GUI. I could only install it. I am using a Toshiba Satellite C75D-A with a AMD A4- 5000 APU Processor with the Radeon HD Graphics. The computer says i have HyperV but i have to enable it which I can not do. I have already shrunk the drive windows 8.1 is located on. I have turned secure boot off but in order to load i have to switch out of UEFI Boot to CSM Boot to load the USB Drive containing The Live Fedora version. How Can i get past the stuck icon and load installation or is Hyper-V necessary for booting and if so, How do you enable it on a amd processor when there is no security option in the Bios to enable this.?? Thank you for your help!!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2015-08-19 18:58:15 -0500

XAOC gravatar image

I have recently installed fedora 22 workstation in dual boot with Windows 10.

First of all, I think you should boot your USB drive in UEFI mode and not in CSM mode. Otherwise you will end up not seeing your windows OS in the grub bootloader when your install is complete. I can share my installation procedure with you (UEFI mode), hoping it will help...

  1. Deactivate the fast startup option "procedure here"
  2. Deactivate the secure boot in the BIOS
  3. Change the boot order to have USB first
  4. Download the fedora live image and verify the checksum (just to make sure your image is not corrupted) "procedure here"
  5. Prepare your boot media according to the fedora manual instructions (personally I used SUSE Studio Image Writer) "Procedure here"

After these steps I was able to install fedora correctly. I think your problem might be at step 4. Your fedora image might be corrupted. Also, in order to boot in UEFI make sure to use a proper software to create your USB bootable drive (like suggested in setp 5).

Good luck

edit flag offensive delete link more


Good answer! Step five can cause the CSM "requirement" as well, if you use an incompatible universal USB writing tool ie unetbootin.

randomuser gravatar imagerandomuser ( 2015-08-19 19:02:27 -0500 )edit

Thank you for your help. In the end i did step 1-3. I could not figure out how to do a checksum so, I ended up redownloading the version, again. I burned the Disc Image File onto a cd. I had to then run CSM again to boot the cd, because for some reason when i reinstalled windows 8 after the first Fedora Server installation it booted it with UEFI. So, In order for me to run windows I have to use UEFI and Fedora is CSM, but now that i have made it to installation to drive it runs Fedora fine. I don't know what i did wrong with this process but, for some reason it worked.I greatly appreciate it.

Belander21 gravatar imageBelander21 ( 2015-08-19 23:14:59 -0500 )edit

@Belander21 The wrong part was not verifying your download, and using CSM.

randomuser gravatar imagerandomuser ( 2015-08-20 08:48:54 -0500 )edit

Question Tools


Asked: 2015-08-19 13:00:13 -0500

Seen: 1,071 times

Last updated: Aug 19 '15