Ask Your Question
2

Fedora 22 UI is unresponsive for 2 seconds for every new dialog

asked 2015-08-18 05:23:55 -0500

Geoffrey De Smet gravatar image

updated 2016-04-28 05:16:16 -0500

Also reproduced on Fedora 23.

On a brand new computer, I 've installed Fedora 22 (gnome 3 default, 2 monitors, nothing special), but if I leave it on for more than few hours, every UI (Firefox, IntelliJ, ...) that opens a pop-up menu or a dialog freezes the screen for 1 to 3 seconds before appearing/disappearing.

This is very disruptive - how do I fix it or analyse the problem?

Diagnose info based on comment questions:

  • According to lspcimy graphics card is VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
  • When it happens, memory is at 5.9GB (18.7%) of 31.3GB. Swap is 0. So it's not caused by swapping
  • When it happens, CPU is not higher than 4% on any of my 8 cores. The process monitor doesn't refresh on the screen during the dialog freeze, but afterwards it does show the same very low CPU for that time. Network history doesn't spike either. Memory neither. None of these 3 resources (cpu, memory, network) show any change during the dialog 2 second freeze.
  • When it happens, sudo journalctl -fshowed gnome-session[1786]: (gnome-shell:2073): GLib-GObject-WARNING **: gsignal.c:2569: instance '0x376ee90' has no handler with id '8758343' 6 times when I opened 1 dialog for IntelliJ. But it showed nothing when I opened the Firefox About dialog or Thunderbird new mail dialog. But ALL those dialogs hung for at least 2 seconds.
  • When it happens, software center does say "Software up to date" and "last checked 06:50" this time. So maybe software updates is innocent. OTH It only happens after the computer is active for several hours. In fact, I wouldn't be surprised it's only in the mornings, after the daily update at 06:50 (and then it bugs me so much that I reboot).

It's gotten so bad that even gnome crashed on me. Here's the journaltlc -r of when that happened.

Here's my fpaste --sysinfo

abrt-cli ls leads to this bug report

edit retag flag offensive close merge delete

Comments

Strangely enough, rebooting the machine makes it go away for a few hours - then it comes back. It seems like it starts hanging on every dialog opening as soon as there are updates to be installed?

Geoffrey De Smet gravatar imageGeoffrey De Smet ( 2015-08-19 02:37:08 -0500 )edit
1

Looks like some graphics driver issue - could you check the memory usage after reboot and after few hours?

covex gravatar imagecovex ( 2015-08-19 11:47:30 -0500 )edit

Looks like I have an Intel graphics card (see new info in question). Does a vanilla Fedora installation automatically uses the best driver for that?

Geoffrey De Smet gravatar imageGeoffrey De Smet ( 2015-08-20 07:19:15 -0500 )edit
1

Yes Fedora use best driver for Intel video cards, now can you check your memory usage when that happen, maybe you are using swap memory at that moment and that is why it gets like that.

aeperezt gravatar imageaeperezt ( 2015-08-20 10:07:39 -0500 )edit
2

This is an odd one... when it starts happening, watch sudo journalctl -f and see if any clues are revealed.

randomuser gravatar imagerandomuser ( 2015-08-20 14:05:21 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-09-29 10:07:09 -0500

Geoffrey De Smet gravatar image

updated 2015-10-01 04:52:36 -0500

Workaround to temporary fix the problem without rebooting the computer: Press ALT-F2 to bring up a prompt and type "r". It will reboot the Gnome Shell and all your open windows will return. The annoying 2 second freezes will go a away for a few hours.

This workaround can permanently freeze some of the open nautilus windows.

edit flag offensive delete link more

Comments

Have you installed any third-party extension? I'm curious but why did you choose to go with F22 being F23 around the corner? I just switched to it (F23 Beta) and with the exception of a minor bug with GDM everything else is working nicely, I encourage you to give it a try :)

msx gravatar imagemsx ( 2015-09-29 14:26:55 -0500 )edit

I have only installed the Gnome 3 toolbar from the gnome 3 website. Everything else is very vanilla. I do got 2 monitors: one connected with HDMI and one connected with DVI-D, both on an Intel graphics card. We're clearly dealing with a resource leak of some sort.

Geoffrey De Smet gravatar imageGeoffrey De Smet ( 2015-09-30 02:09:46 -0500 )edit
1

I too experienced very poor performance when attaching an external monitor in the past.

msx gravatar imagemsx ( 2015-10-01 07:15:53 -0500 )edit
0

answered 2016-04-28 12:12:35 -0500

genodeftest gravatar image

In case this is still happening to you, you should report a bug against gnome-shell.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2015-08-18 05:23:55 -0500

Seen: 392 times

Last updated: Apr 28 '16