Ask Your Question
0

Unable to Set up Static ip for wireless adaptor in fedora 16

asked 2012-07-11 08:25:30 -0500

Jaydev gravatar image

Hi,

I'm not able to configure a wireless connection with static ip. Whenever I select "Manual" option on Network settings window "Save" button at the bottom goes gray. I cant click on that. But it take DHCP addresses. Could you please help ?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2012-07-11 12:02:30 -0500

Akshay gravatar image

Navigate to /etc/sysconfig/network-scripts/

[root@akshay ~]#cd /etc/sysconfig/network-scripts/

[root@akshay network-scripts]#vi ifcfg-eth0
    DEVICE=eth0
    TYPE=Ethernet
    ONBOOT=yes
    BOOTPROTO=none
    IPADDR=192.168.0.100
    NETMASK=255.255.255.0
    GATEWAY=192.168.0.1
    HWADDR=00:0F:xx:xx:xx:53
    USERCTL=no
    USERCTL=no

Restart your interface to apply the changes.

[root@akshay ~]#ifdown eth0
[root@akshay ~]#ifup eth0

To update your dns server settings, modify the /etc/resolv.conf.

[root@akshay ~]#vi /etc/resolv.conf

Replace the contents of the resolv.conf file with the parameters below. The first parameter “search” is your search path followed the nameserver parameters which hold the IPs for your primary and secondary DNS servers.

search example.com
nameserver 192.168.0.5
nameserver 192.168.0.6

Note: you can change parameters according to your requirement this is just an example of "How to configure static ip"

edit flag offensive delete link more
0

answered 2012-07-11 11:37:15 -0500

slybloty gravatar image

You have to add the new manual address that you want to assign to it: IP address, netmask, and gateway.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-07-11 08:25:30 -0500

Seen: 1,341 times

Last updated: Jul 11 '12