Ask Your Question
0

Reliance Netconnect BB+

asked 2011-12-04 00:15:20 -0600

Chetan Patil gravatar image

I have ZTE AC 2726 Reliance BB+. I downloaded and configured .rpm from http://www.rcom.co.in/Rcom/personal/internet/wireless_internet.html#

However that application is not opening when I try do to so.

Has anyone able to resolve the issue?

Also I'm not able to connect with the help of Mobile Broadband from Network Manager.

There are too many forums providing solutions to this however the one I tried are not working.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2011-12-04 03:50:00 -0600

SoumyaC gravatar image

Use wvdial to do configure Reliance BB+. Install wvdial as shown below -

# yum install wvdial

After connecting your Reliance USB, just type in command lsusb

# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 15d9:0a37 Trust International B.V. Mouse
Bus 002 Device 002: ID 064e:a101 Suyin Corp. Acer CrystalEye Webcam
Bus 003 Device 004: ID 19d2:fff1 ONDA Communication S.p.A.

It should come as some ONDA Communication or Huawei or Quallcom. Get the number, here it is (19d2:fff1)

Then give the following command -

# modprobe usbserial vendor=0x19d2 product=0×fff1

Then edit the /etc/wvdial.conf file -

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Stupid Mode = 1
Modem Type = USB Modem
ISDN = 0
Phone = #777
New PPPD = yes
Modem = /dev/ttyUSB0
Username = <username>
Password = <password> 
CBaud = 460800

After editing the /etc/wvdial.conf ( With your username and password and the Phone field [For Reliance BB+ its #777] ) start wvdial from shell

# wvdial

You should get connected with internet following the above procedure.

edit flag offensive delete link more

Comments

Paste the contents of the file /etc/resolv.conf

SoumyaC gravatar imageSoumyaC ( 2011-12-04 07:19:04 -0600 )edit

When you get the ip address via wvdial that time check the contents of the file. Also are you using Fedora16 ? If yes, then don't you have a option of mobile broadband in your Network Settings in NetworkManager ?

SoumyaC gravatar imageSoumyaC ( 2011-12-04 07:41:33 -0600 )edit

when you have connected the usb modem, just hit on the wvdialconf command to check if the model gets detected or not.

SoumyaC gravatar imageSoumyaC ( 2011-12-04 08:22:12 -0600 )edit

@Chetan Patil : It should work if it gets detected, very strange that it doesn't :( I dont have a Reliance modem to try out, but if this doesn't work, may be you cant try and reboot your system and check if NetworkManager detects the usb as mobile broadband.

SoumyaC gravatar imageSoumyaC ( 2011-12-04 08:55:38 -0600 )edit

Normally you don't have to edit ifcfg file. When I uses BB+ a month or two back, configuring wvdial like I said above worked for me and I guess for maximum people if you google out the same problem in internet.

SoumyaC gravatar imageSoumyaC ( 2011-12-05 03:55:03 -0600 )edit

Question Tools

Stats

Asked: 2011-12-04 00:15:20 -0600

Seen: 1,378 times

Last updated: Dec 04 '11