Ask Your Question
0

gnome gui freeze before login on F22/4.1.3

asked 2015-08-11 05:40:29 -0500

roemer gravatar image

I've installed the latest (22) fedora workstation.iso from the fedora side. After installation the system hangs right before gnomes login screen is launched.

If I only boot into runlevel 3 everything works fine. I ran a dnf upgrade, so right now I'm on the latest kernel (4.1.3). I'm pretty shure this is a grafic driver issue (ATI HD 6300).

Any suggestions on how to get the system running?

edit retag flag offensive close merge delete

Comments

gnome crashes 2 times until today, i dont know what's wrong and how to explain it better, why it start like that, but after i running dnf update and kernel upgrade to 4.1.3.

yonkyunior gravatar imageyonkyunior ( 2015-08-12 20:32:20 -0500 )edit

I've tried different kernel flags and removed some libraries, still no success. Its sad that I have to say that linux is still not a usable work station os, especially because this is due to the driver situation.

roemer gravatar imageroemer ( 2015-08-13 00:39:53 -0500 )edit

it's always perfect, depends on you and your hardware. if you more than serious and doesnt want to go back to your old OS, doesnt care how much money you spend, then choose who give the best support and reliable. If you like an adventure, who give you story to tell and problem that you solve alone, then choose it properly. Do check another linux a try, live cd is enough to tell you.

yonkyunior gravatar imageyonkyunior ( 2015-08-13 11:40:48 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-08-13 13:05:04 -0500

BRPocock gravatar image

updated 2015-08-13 13:10:02 -0500

What error(s) are found in the journal when it “freezes?”

If you boot to single-user or terminal mode, you can review the journal from the prior boot with journalctl -b -1 (-boot 0 is current, so -1 is the prior boot)

If it's actually a problem with the display drivers, you may find something was logged by X, itself. There's a possibility you could start using nomodeset, or xforcevesa ; you might also consider using ATI's own drivers, as https://bluehatrecord.wordpress.com/2... ( updated with better info)

Several ATI users with issues also simply switched from gdm to lightdm and found that things started working, it seems.

edit flag offensive delete link more

Comments

I just updated grub2 because I set GRUB_DEFAULT=saved (which is not working btw) and now it doesn't crash any more. The screen ist still scrambled a few times, but then it settles down and runs smoothly.

jeah....

roemer gravatar imageroemer ( 2015-08-19 07:36:48 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-08-11 05:40:29 -0500

Seen: 680 times

Last updated: Aug 13 '15