Ask Your Question
1

Headphones (Plugged In) no longer working (F21)

asked 2015-08-11 05:25:01 -0500

QdAr4h0HI gravatar image

Out of the blue my headphones have stopped working. Music plays fine out of the speakers, but when I plug my headphones in it is silent even though pavucontrol shows that sound is being output.

I know this is not an underlying hardware issue because sound fine out of both outputs in Windows and when I boot from an F21 live usb.

Here is my (working) output from alsa-info.sh when running the live usb http://www.alsa-project.org/db/?f=ae1...

And here is the alsa-info.sh output for the failing setup (speakers work, headphones dont) http://www.alsa-project.org/db/?f=f3f...

The two main differences that I've found are that:

  1. snoop is set to Y on the functioning setup under "Soundcards recognised by ALSA" whereas it's set to -1 on the failed section
  2. The dmesg output shows hdaudioC1D0 is under sound in the functioning output and snd_hda_codec_realtek on the failing one.

Another incidental difference is that when running the LiveUSB three devices show up in the GNOME "sound" settings - "Headphones", "Speakers" and "Analog Audio Device" whereas in the failing version just "Headphones" and "Speakers"

An ideal fix would just be for me to be able to copy some config files from the live usb to my HDD, but asound.conf is empty and I haven't been able to find any others.

Any help greatly appreciated.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2015-08-11 07:57:12 -0500

QdAr4h0HI gravatar image

updated 2015-08-11 10:29:59 -0500

I don't think this really should have been a solution, but I've upgraded the whole system to F22 and it's now working great. I have no idea what it was, but I thought i'd post the successful alsa-info.txt in case somebody can work out what it might have been http://www.alsa-project.org/db/?f=782...

EDIT:

I managed to cause the same problem again by playing with alsamixer on the command line and toggling the "Auto Mute" option. This seems to have written something to /var/lib/alsa/asound.state which causes the problem and toggling "Auto Mute" fails to resolve it.

I have resolved the problem now by deleting /var/lib/alsa/asound.state and rebooting which automatically creates a new config file

EDIT2:

Here's a diff of the two asound.state files

state.PCH {
control.1 {
    iface MIXER

        name 'Headphone Playback Volume'
-       value.0 87
-       value.1 87
+       value.0 0
+       value.1 0
        comment {
            access 'read write'
            type INTEGER
@@ -261,15 +261,15 @@ state.PCH {
            range '0 - 87'
            dbmin -6525
            dbmax 0
-           dbvalue.0 0
-           dbvalue.1 0
+           dbvalue.0 -6525
+           dbvalue.1 -6525
        }
    }
    control.2 {
        iface MIXER
        name 'Headphone Playback Switch'
-       value.0 true
-       value.1 true
+       value.0 false
+       value.1 false
        comment {
            access 'read write'
            type BOOLEAN
@@ -279,8 +279,8 @@ state.PCH {
    control.3 {
        iface MIXER
        name 'Speaker Playback Volume'
-       value.0 0
-       value.1 0
+       value.0 87
+       value.1 87
        comment {
            access 'read write'
            type INTEGER
@@ -288,15 +288,15 @@ state.PCH {
            range '0 - 87'
            dbmin -6525
            dbmax 0
-           dbvalue.0 -6525
-           dbvalue.1 -6525
+           dbvalue.0 0
+           dbvalue.1 0
        }
    }
    control.4 {
        iface MIXER
        name 'Speaker Playback Switch'
-       value.0 false
-       value.1 false
+       value.0 true
+       value.1 true
        comment {
            access 'read write'
            type BOOLEAN
@@ -468,7 +468,7 @@ state.PCH {
    control.17 {
        iface CARD
        name 'Headphone Mic Jack'
-       value true
+       value false
        comment {
            access read
            type BOOLEAN
edit flag offensive delete link more
1

answered 2015-08-11 06:22:36 -0500

George Carlin gravatar image

click settings > sound > digital output

it will work

edit flag offensive delete link more

Comments

Thanks for the help - I'm afraid I have no 'digital output' in my list http://imgur.com/fQ7Rl6D

QdAr4h0HI gravatar imageQdAr4h0HI ( 2015-08-11 06:27:46 -0500 )edit

i had this the same problem before my earphone will not work, so i click the headset output or my usb audiojack with is my digital audio output after that it work properly.

George Carlin gravatar imageGeorge Carlin ( 2015-08-11 06:38:58 -0500 )edit

Thanks again! Afraid no luck for me.

QdAr4h0HI gravatar imageQdAr4h0HI ( 2015-08-11 07:56:30 -0500 )edit
0

answered 2015-08-17 18:44:52 -0500

sergiomb gravatar image

updated 2015-08-18 08:09:58 -0500

Hi, I know that you have gnome but from https://userbase.kde.org/Sound_Proble...

I recommend

rm -rf .pulse/
rm -rf .pulse-cookie 
rm -rf .config/pulse/

restart pulseaudio with:

killall pulseaudio

and run

/usr/bin/pavucontrol

on output devices try change port , it worked for me !

UPDATE : Now it is pretty clear to me how I can put headphones working :

I go to program: pavucontrol , go to tab : output devices and change port to Speakers (unavailable) and works all the time .

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2015-08-11 05:25:01 -0500

Seen: 4,604 times

Last updated: Aug 18 '15