Ask Your Question
0

how to make zte mf825 working?

asked 2015-08-06 02:56:14 -0600

updated 2015-08-06 06:39:19 -0600

hello, i'm new user, i have installed fedora 22 in my hp 4421s, here the lsusb info and usb-devices fyi, my zte mf825 is working with windows and i changed the behavior to download mode/diagnostic mode to connect without webGUI.


[yonkyunior@blackangel ~]$ lsusb
Bus 002 Device 006: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 002 Device 005: ID 19d2:0016 ZTE WCDMA Technologies MSM 
Bus 002 Device 004: ID 2109:0711 VIA Labs, Inc. 
Bus 002 Device 003: ID 0000:0538  
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 006: ID 05c8:0403 Cheng Uei Precision Industry Co., Ltd (Foxlink) Webcam
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[yonkyunior@blackangel ~]$ usb-devices

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 2
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev=04.00
S:  Manufacturer=Linux 4.0.4-301.fc22.x86_64 ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=0000:00:1a.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=480 MxCh= 6
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=8087 ProdID=0020 Rev=00.00
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=01 Lev=02 Prnt=02 Port=04 Cnt=01 Dev#=  6 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=ef(misc ) Sub=02 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=05c8 ProdID=0403 Rev=01.05
S:  Manufacturer=Foxlink
S:  Product=HP Webcam [2 MP Fixed]
S:  SerialNumber=200909240102
C:  #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=500mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=0e(video) Sub=01 Prot=00 Driver=uvcvideo
I:  If#= 1 Alt= 0 #EPs= 0 Cls=0e(video) Sub=02 Prot=00 Driver=uvcvideo

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 2
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev=04.00
S:  Manufacturer=Linux 4.0.4-301.fc22.x86_64 ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=0000:00:1d.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-08-06 14:06:43 -0600

anishjp gravatar image

Enable the Network manager service first

systemctl enable NetworkManager.service
systemctl start NetworkManager.service

Confirm it is running by

systemctl status NetworkManager.service

Connect your USB modem. Give it a couple of seconds and then click on the top right drop down menu and you should see "Mobile broadband". Click on "Mobile broadband settings" and create a profile for your network operator with all the relevant details. Save and then each time just click on the saved profile and it will connect to the internet.

edit flag offensive delete link more

Comments

the command works but, when i connect my usb modem, MobileBroadband menu do not showing up.

yonkyunior gravatar imageyonkyunior ( 2015-08-06 16:15:12 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2015-08-06 02:56:14 -0600

Seen: 457 times

Last updated: Aug 06 '15