Ask Your Question
2

fedora 18 extremely loud fan, hot laptop

asked 2013-01-31 21:33:13 -0500

malxxxl gravatar image

updated 2013-02-02 01:18:01 -0500

Jomoos gravatar image

I'm new to Fedora and have successfully installed fedora 18 on my samsung laptop with windows 7 64-bit and ATI HD Radeon 3000. Whenever running F18 my laptop's fan turns on and will be on until I switch to Windows OS and will eventually cool off. I asked a friend and he installed version 3.7.4-204.fc.18x86_64 and still no luck. I have done some research and have been reading that I may need to install graphics card driver or upgrade fedora to the "appropriate" kernel. I saw my friend installing 3.7.4 through commands. Is it possible erase/delete the current version my friend installed because hasn't fixed the problem. When I turn my laptop on I have 4 options which include

  1. F18 version 3.7.4.
  2. Fedora-18
  3. windows 7
  4. recovery.

I guess my question is

  • how can I fix my problem with regards to the fan running extremely loud? the laptop gets too loud and hot.
  • It runs loud without me doing anything, should I install a driver for my graphics card? if so, how?
  • should I install a different version of fedora 18? if so which version? I was told I may have to install version 3.6.

I forgot to include that when running F-18, it drains my battery life per minute and that doesn't happen when running windows 7.

Please keep in mind that I'm new to fedora and if you suggest some tips I would highly appreciate it if you could be very specific and detailed.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-02-01 12:15:51 -0500

PaulCarroty gravatar image

updated 2013-02-02 01:24:03 -0500

Jomoos gravatar image
echo low > /sys/class/drm/card0/device/power_profile

you also can use default, mid, high profiles and cpupower for frequence scaling.

edit flag offensive delete link more
0

answered 2013-02-01 08:34:37 -0500

fergatron gravatar image

updated 2013-02-02 01:19:45 -0500

Jomoos gravatar image

You may want to try other distros to see if it's Fedora-specific. Does this fan issue happen when running the Fedora LiveCD? If it does then try Ubuntu or ArchLinux without having to install them.

I wouldn't think your graphics card would have a fan on it since it's in a laptop, but I'm no hardware expert. I'm going to assume that there's some process that's asking too much of your CPU. You can open your gnome-terminal and run the TOP command to see if your CPU is being hijacked by a particular application or process.

> # top

As for your video card you can visit nVidia's web site and download their proprietary drivers if you really believe that's the source of your problem. Maybe their drivers will work better. Here's an article to help you with that. http://fedorasolved.org/video-solutions/nvidia-bin

edit flag offensive delete link more

Comments

He may have to do yum install htop to install top command, before running it.

How nVidia's website be of use to him? He said he have an ATI Readon card.

Jomoos gravatar imageJomoos ( 2013-02-02 01:22:31 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2013-01-31 21:33:13 -0500

Seen: 3,174 times

Last updated: Feb 02 '13