Ask Your Question
0

ttyrec runs Out of pty's [closed]

asked 2011-09-29 04:56:22 -0500

satyaakam gravatar image

ttyrec-1.0.8-2.1.i386 is installed on Fedora 15 , when i run the command

$ttyrec Out of pty's Terminated

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by zoltanh721
close date 2014-06-27 17:44:56.727056

3 Answers

Sort by ยป oldest newest most voted
0

answered 2011-09-29 06:49:10 -0500

shanks gravatar image

Ok, this looks like a bug.

So what you can do is:

  1. remove the installed ttyrec.
  2. wget and install the src rpm from https://bugzilla.redhat.com/show_bug.cgi?id=741706
  3. go to the its source directory and untar it.

    tar -zxvf ttyrec-1.0.8.tar.gz

  4. patch the source with the included "ttyrec-Makefile.patch", then it works for UNIX98 pty standard.

    ttyrec-1.0.8]# patch -p1 < ../ttyrec-Makefile.patch1.2.3.3

  5. Make sure you have "libbsd-devel" installed, else

    yum install libbsd-devel

  6. make the source

    ttyrec-1.0.8]# make

  7. copy the binaries to /usr/bin

    ttyrec-1.0.8]# cp ttyrec ttytime ttyrecord /usr/bin/

  8. Execute "ttyrec"

edit flag offensive delete link more
1

answered 2011-09-29 23:47:15 -0500

satyaakam gravatar image

instead built the RPM

rpmbuild --rebuild ttyrec-1.0.8-2.src.rpm

it works now.

edit flag offensive delete link more
0

answered 2012-01-24 18:13:33 -0500

egon gravatar image

So, it looks like libbsd is available for fedora, but not centos or redhat. What's the solution for those distros?

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2011-09-29 04:56:22 -0500

Seen: 2,065 times

Last updated: Jan 24 '12