How do i make systemctl programs launch on the login screen?

asked 2015-07-27 08:10:29 -0500

nejohopper gravatar image

updated 2015-07-27 10:21:15 -0500

I recently upgraded from fedora 21 to 22 (fresh install). I use the computer remotely, so i always set my realvnc server to autostart (sudo systemctl enable vncserver-x11-serviced)

In previous fedora versions (20 and 21), this would cause it to load on boot, so i could connect remotely at the user logon screen, and even if the screen later locked i was still able to reconnect. Essentially, it would continuously run as long as it wasnt on standby.

However, in 22 it doesnt do that. The user has to log in before vnc loads, and if the lock screen comes up or the computer goes into standby, it closes the vnc server. Relogging in manually on the computer from the lockscreen doesnt reload vnc, which is a problem as i an usually not physically near it.

Is there any way to make this autostart program behave as it did in 21, or to force it to continue running in the background?

Thanks in advance for your help. :)

edit retag flag offensive close merge delete

Comments

How are you connecting to VNC; over SSH, or are you trying to open a public VNC port to your local network? … If the latter, have you configured /lib/systemd/system/vncserver@.service to set it up?

BRPocock gravatar imageBRPocock ( 2015-07-27 10:30:54 -0500 )edit