Ask Your Question

What could cause the alt key to stop working in two terminal apps?

asked 2011-12-01 09:20:27 -0500

ryran gravatar image

updated 2011-12-07 08:51:44 -0500

I use lots of keyboard shortcuts when I'm working with bash in a terminal. Two that I use heavily are Alt-d and Alt-. to delete the following word and to bring in the last argument of the previous command, respectively. In the last twenty-four hours--somewhere in the middle of a marathon coding session--I noticed that they stopped working in both of the terminal applications that I use heavily (Terminator and Guake); however, Alt key presses are still registered by the apps themselves (e.g., in Terminator, Alt-Left switches to the window frame on the left, and that works). Edit: In other news Esc-d or Esc-. work. So I'm gonna look into the whole meta thing...

Also, my mind was just blown when I realized that Alt still works in gnome-terminal (which I never use). Before that I thought this was a bash issue. Alt-key combos also work just fine every where else in my Gnome desktop & applications. WTH!

Any pointers?

edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted

answered 2011-12-07 08:57:10 -0500

ryran gravatar image

updated 2011-12-14 15:12:07 -0500

@Izap had the same problem and tracked it down in another question of his.

Basically, a GTK2 change broke meta keys for vte-based terminals. Izap came up with a work-around, and I posted what I consider an even better work-around here.

Short version:

yum --enablerepo=updates-testing update vte

That fixes terminator and guake on my system.

edit flag offensive delete link more

answered 2011-12-07 08:25:24 -0500

twic gravatar image

[answering because i can't comment]

We have the same problem. In our case, it was an upgrade to Fedora 16 that caused this. You didn't by any chance update to Fedora 16 at some point, did you? Seems extraordinarily unlikely, but i have to ask.

We see this under GNOME 3 and Xfce.

We have noticed that we can still use the escape key to get these behaviours - escape then dot does the same as alt-dot. That's standard; composing with escape is the traditional way of sending a meta on keyboards which lack a meta key. Chording with alt should normally do the same, but doesn't.

edit flag offensive delete link more

answered 2011-12-14 14:49:52 -0500

alexlan gravatar image

For gtk3-based apps (such as gnome-terminal) in Fedora 16: the pending update for vte3 in updates-testing fixes this:

to fix simply run (as root):

yum --enablerepo=updates-testing install vte3

Note that this doesn't fix the gtk2-based apps like terminator

edit flag offensive delete link more

answered 2011-12-07 14:39:58 -0500

lzap gravatar image

Yup, the workaround is to downgrade to previous gtk2 and hold on with upgrading a bit until they fix the issue.

sudo rpm -Uvh --force gtk2*rpm
edit flag offensive delete link more

answered 2011-12-01 18:22:16 -0500

taiss gravatar image

Which alt key doesn't work? The left one or the right one?

edit flag offensive delete link more

Question Tools



Asked: 2011-12-01 09:20:27 -0500

Seen: 1,461 times

Last updated: Dec 14 '11