Ask Your Question
1

GPG Key issues using RPMFusion on Fedora 22

asked 2015-07-25 17:33:50 -0500

DigitalFlow gravatar image

updated 2015-07-25 18:57:05 -0500

mether gravatar image

So I recently switched to Fedora and wanted to install RPM fusion. After installing it, I tried to install steam and got the warning:

warning: /var/cache/dnf/x86_64/22/fedora/packages/alsa-lib-1.0.29-1.fc22.i686.rpm: Header V3 RSA/SHA256 Signature, key ID 8e1431d5: NOKEY GPG-Schlüssel 0x8E1431D5 wird importiert: Benutzer-ID : »Fedora (22) fedora@fedoraproject.org« Fingerabdruck: C527 EA07 A934 9B58 9C35 E1BF 11AD C094 8E14 31D5 Von : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-22-x86_64

As I found out, all RPM packages store their keys in /etc/pki/rpm-gpg and so I wanted, to import them into rpm. I accidentally ran "rpm --import RPM-GPG-KEY-rpmfusion-free-fedora-24" and the non-free one instead of those for version 22. Although I imported the keys for version 22 also afterwards, I'm still receiving the warning when trying to install steam with dnf. So my question is: Why is it prompting for importing this key everytime and is it bad, that I imported the version 24 version of the rpmfusion keys also? (There is no version 24 of fedora afaik, so why is this key existing at all?)

Thank you very much for your help.

Kind Regards, DigitalFlow

edit retag flag offensive close merge delete

Comments

If you look closely, you'll see that about half of the files in that directory are actually links. Do you have them? Also, it's probably a good idea to use rpm to remove the keys for Fedora 24 because you're never going to need it (until it comes out, that is) and it may be causing some confusion.

sideburns gravatar imagesideburns ( 2015-07-25 17:55:13 -0500 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2015-07-26 08:34:30 -0500

sergiomb gravatar image

You may do :

rpm --import "http://rpmfusion.org/keys?action=AttachFile&do=get&target=RPM-GPG-KEY-rpmfusion-free-fedora-22" "http://rpmfusion.org/keys?action=AttachFile&do=get&target=RPM-GPG-KEY-rpmfusion-nonfree-fedora-22"
dnf install http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-22.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-22.noarch.rpm

with gpg verification or no need use --nogpg

edit flag offensive delete link more
0

answered 2015-07-26 01:34:27 -0500

davidva gravatar image

Well human error, try reinstall rpmfusion repositories.

1) su
2) dnf -y reinstall --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

Also, you can disable check GPG key and install packages normally, but you need edit the repository ;)

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2015-07-25 17:33:50 -0500

Seen: 3,876 times

Last updated: Jul 26 '15