Ask Your Question
1

Annoying removable drive notification

asked 2015-07-23 23:19:41 -0500

deshmukh gravatar image

I am running Fedora22 Workstation.

When I connect a removable drive, a notification pops up informing me about the drive being connected.

Usually, such notifications die after a while or when some keyboard/ mouse action happens.

But these removable drive notifications refuse to die away till I manually click on the 'X' button.

What is wrong with my setup? How can I set it right?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-07-24 02:55:28 -0500

jpeg gravatar image

updated 2015-07-24 02:59:43 -0500

That's normal behaviour of the GNOME desktop, but if you don't like it, you can change it using the Settings program. Open the applications dashboard and scroll down, or type in 'settings' to find it.

In that program, click on the Notifications entry, and then you can click the switch that says Show Popup Banners to disable those notifications globally, or you can scroll down to a specific program you want to disable them for and click the switch under its heading. You can still have other types of notifications with sliding notifications disabled, such as event sounds.

I don't have a blank drive available so I can't say for sure, but I think disabling sliding notifications for the Files program entry will disable sliding notifications for blank drives. I unfortunately cannot test that possibility at the moment, maybe someone else can confirm.

For CDs, DVDs, and removable drives with pictures, music, programs or live images on them, you can go to the Settings program again and click Details, then Removable Media, and choose the type of media you want and set the handler to "Do nothing", or click the "Never prompt on media insertion" checkbox to disable actions globally.

If you don't already know, there are also alternative desktops available in the repositories such as KDE or Cinnamon that are more configurable than GNOME, and you may prefer the more traditional way they handle notifications, i.e. a small message near the system tray that shortly fades away.

edit flag offensive delete link more

Comments

@jpeg thanks for a detailed reply. But it did not answer my question. May be, it was not a good question. I WANT those notifications. But I want them to go away like other notifications do. My problem is: ONLY when an external disk is connected, does a notification popo up that refuses to go away till I kick it off!!

deshmukh gravatar imagedeshmukh ( 2015-07-24 09:06:40 -0500 )edit
1

Unfortunately, there is no setting in GNOME to make removable drive notifications disappear like others. It seems to be a bug, but its several years old now and there have been a few bug reports filed about it already, so I'm not sure when it will be fixed, if GNOME is actually even planning to. There are no extensions that solve it either at the moment. Disabling the notifications for removable media is the only fix right now. You may be able to get around it by disabling all GNOME notifications and installing a separate notification system in its place. There are several in the repositories.

jpeg gravatar imagejpeg ( 2015-07-24 14:56:43 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-07-23 23:19:41 -0500

Seen: 276 times

Last updated: Jul 24 '15