Ask Your Question
1

How do I set primary monitor for GDM on Wayland?

asked 2015-07-16 13:29:38 -0500

darakus gravatar image

I've recently done a new install of Fedora 22 Workstation and I cant seem to find a way to set the primary monitor for GDM on Wayland.

In the past I've simply copied ~/.config/monitors.xml to /var/lib/gdm/.config/monitors.xml and that set my GDM primary monitor to the primary monitor from my user account. However, due to the change to Wayland on the login screen this does not work anymore.

Disabling Wayland on GDM is a workaround, but I'm wondering what is the proper way to set the primary display on GDM now? Thanks for any advice anyone can give.

There is also: https://bugzilla.redhat.com/show_bug....

So maybe this is just not possible yet?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-07-16 16:00:49 -0500

darakus gravatar image

In order to get this to work you must click the gear icon on GDM login screen and change your session to GNOME on Wayland. Then from settings configure your monitors the way you like. This will generate a Wayland compatible monitors.xml file in ~/.config/ that you can copy into the gdm directory at /var/lib/gdm/.config/.

After a reboot the new config should work.

You can then change your login session back to GNOME.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-07-16 13:29:38 -0500

Seen: 2,661 times

Last updated: Jul 16 '15