Ask Your Question
0

Fedora 4.0.7-300 Not boot at all

asked 2015-07-14 13:25:40 -0500

Suvo gravatar image

Since update from 4.0.6-300 to 4.0.7-300 Boot fail always.

Currently I am using Fedora 22 with manual boot selection with 4.0.6-300

My doubt is once again it is Nvidia issue with Fedora OR Fedora issue with Nvidia. {It is very disappointing that since I am using Fedora (My favourite Linux) I always facing problem with Nvidia, it is like Fedora and Nvidia are born enemy to each other}.

edit retag flag offensive close merge delete

Comments

There's more than one way to install the nVidia drivers, and some are easier to update than others. Which one did you use?

sideburns gravatar imagesideburns ( 2015-07-14 13:47:00 -0500 )edit

I installed it from RPM Fusion, both akmod and kmod.

Suvo gravatar imageSuvo ( 2015-07-14 13:51:12 -0500 )edit

By “boot fail,” do you mean that the graphical login screen does not appear? Does Control+Alt+F6 still give you a text login?

BRPocock gravatar imageBRPocock ( 2015-07-14 13:58:14 -0500 )edit

Use dnf list installed kmod-nvidia to find out if you have the proper version installed for 4.0.6-300. If not, we'll need to look into why akmod-nvidia didn't build it.

sideburns gravatar imagesideburns ( 2015-07-14 14:04:34 -0500 )edit

Yes, boot fail mean no graphical login screen. But there is many text on the screen instead of graphical login screen. Left portion display "OK" and right portion some information like started _________ service, waiting for _________ service ("______" means service name). After all service are started and all are OK, nothing happen (nothing happen means I waiting for 15 minutes highest). And no key button work it need to power button press on CPU to power off. Not tried Control+Alt+F6.

Suvo gravatar imageSuvo ( 2015-07-14 14:15:55 -0500 )edit

$ dnf list installed kmod-nvidia Fedora 22 - x86_64 116 kB/s | 41 MB 06:04
RPM Fusion for Fedora 22 - Free - Updates 750 B/s | 399 B 00:00
Adobe Systems Incorporated 4.1 kB/s | 1.8 kB 00:00
RPM Fusion for Fedora 22 - Nonfree - Updates 592 B/s | 399 B 00:00
RPM Fusion for Fedora 22 - Free 72 kB/s | 549 kB 00:07
Fedora 22 - x86_64 - Updates 106 kB/s | 11 MB 01:49
Contd..... next comment

Suvo gravatar imageSuvo ( 2015-07-14 14:31:28 -0500 )edit

google-chrome 8.9 kB/s | 3.7 kB 00:00
RPM Fusion for Fedora 22 - Nonfree 49 kB/s | 150 kB 00:03
Last metadata expiration check performed 0:00:00 ago on Wed Jul 15 00:56:46 2015. Error: No matching Packages to list

Suvo gravatar imageSuvo ( 2015-07-14 14:32:30 -0500 )edit

All I needed was the names of the installed packages, not the complete output. Generally, the early output isn't useful unless there are errors. Try this instead: dnf list installed \*kmod-nvidia\* and just list the packages.

sideburns gravatar imagesideburns ( 2015-07-14 16:06:47 -0500 )edit

Installed Packages akmod-nvidia-304xx.x86_64 304.125-3.fc22.10 @System

kmod-nvidia-304xx.x86_64 304.125-3.fc22.10 @System

kmod-nvidia-304xx-4.0.4-301.fc22.x86_64.x86_64 304.125-3.fc22.10 @System

kmod-nvidia-304xx-4.0.6-300.fc22.x86_64.x86_64 304.125-3.fc22.10 @System

Suvo gravatar imageSuvo ( 2015-07-15 10:12:56 -0500 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2015-07-15 12:08:17 -0500

sideburns gravatar image

...and there's your answer: there's no kmod-nvidia installed for your newest kernel. Try updating your system again and see if it includes the missing kmod. If not, run (as root) akmods --force and see if it builds the module. If not, let us know what the error message is so that we can find out why not.

edit flag offensive delete link more

Comments

1) Tried updating 2) (As root) tried akmods --force (it display 4.0.6 [ok]) 3) Reboot 4) Ctrl+Alt+F6 5) Login and update (nothing updated) 6) (as root) akmods --force (started building and OK) 7) Reboot 8) Problem Solved 9) Thanks a lot

Suvo gravatar imageSuvo ( 2015-07-15 12:46:38 -0500 )edit
0

answered 2015-07-25 06:24:32 -0500

I was having the same issue with the graphical login going from 4.0.7-300 to 4.0.8-300. I booted back into 4.0.7-300 and then specified the new kernel in akmods

sudo akmods --force --kernels 4.0.8-300.fc22.x86_64

Rebooted and now able to get the graphical login with 4.0.8-300.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2015-07-14 13:05:05 -0500

Seen: 139 times

Last updated: Jul 15 '15