dracut Warning could not boot [closed]

asked 2015-07-13 15:36:04 -0500

Jurrien gravatar image

After upgrading fedora 21 to 22 with yum my system does not boot anymore.

dracut-initqueue[398]: Warning: Could not boot. dracut-initqueue[398]: Warning: /dev/mapper/vg_wbs-lv_root does not exist Starting Dracut Emergency Shell... Warning: /dev/mapper/vg_wbs-lv_root does not exist

After some searching I see that the MDRaid is not started. I run mdadm --assemble --scan and all raid drives are started. After that I have to do a lvm lvchange -a y /dev/mapper/vg_wbs-lv_root and lvm lvchange -a y /dev/mapper/vg_wbs-lv_swap and I type exit and the system boots normal.

Probably I need to rebuild the initramfs as some site suggest but that does not work.

What else could I do or check to solve this?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Jurrien
close date 2015-07-15 14:29:05.746013


Using man dracut and man dracut.cmdline, there are options to have those things done on the kernel command line. Firstly, paste the output of dracut --print-cmdline.

NuuN gravatar imageNuuN ( 2015-07-13 17:07:44 -0500 )edit

The output of the command:

dracut --print-cmdline
 rd.md.uuid=1dbce3f6:e09b8134:330a59c2:a685362c  rd.md.uuid=02cc4560:4eb2ff4d:330a59c2:a685362c  root=/dev/mapper/vg_wbs-lv_root rootflags=rw,relatime,data=ordered rootfstype=ext4
Jurrien gravatar imageJurrien ( 2015-07-14 04:42:04 -0500 )edit

I lack knowledge about disk arrays(md and dm). Adding rd.auto rd.md.waitclean=1 to your kernel command line seems like a feasible workaround. Care to test it?

NuuN gravatar imageNuuN ( 2015-07-14 11:30:21 -0500 )edit

Great! That did the trick! Thanks a lot!

Jurrien gravatar imageJurrien ( 2015-07-15 14:28:32 -0500 )edit