Ask Your Question
0

Fedora 21 gnome-session dies with freenx-server

asked 2015-07-07 01:44:45 -0500

ArtND76 gravatar image

updated 2015-07-07 15:40:23 -0500

I just installed Fedora 21 on an Intel R1304JP40C Server that I want to use remotely. I installed both nxagent and freenx-server packages in a similar manner to a working configuration I have on CentOS 6. Everything works fine until after login and it tries to run gnome-session, where it dies.

Now in desperation I did an install of the KDE desktop on the same machine - and freenx-server works perfectly with a KDE desktop connection.

So what is the issue with gnome-session? It worked on a local display when I was physically at the server, just not remotely through freenx...

I did see something that looks like my problem here: https://bugs.launchpad.net/ubuntu/+so...

Has this not been fixed in Fedora?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-07-23 11:33:32 -0500

RogerP gravatar image

I have the same problem and really wish someone from Gnome would fix it. I would just run KDE, but it has a mouse problem when running remotely.

edit flag offensive delete link more
0

answered 2015-07-07 13:00:11 -0500

hmaarrfk gravatar image

Until somebody proposes a solution to your issue, you might want to try

https://www.nomachine.com/

It has worked for me in the past.

edit flag offensive delete link more

Comments

Sorry, but the problem is not with freenx-server in particular, it exists for any remote. As I point out in my original question, freenx-server works with KDE but not with gnome-session. The official nomachine version will attempt to run the same gnome-session command and it will therefore fail in the same manner. Apparently Ubuntu has a fix in their gnome-session 3.14 package, but my Fedora 21 gnome-session 3.14 does not. At least when I tried adding '--disable-acceleration-check' to the gnome-session command in /etc/nxserver/node.conf it went from a grey screen hang to a connection abort.

ArtND76 gravatar imageArtND76 ( 2015-07-07 15:35:48 -0500 )edit

Hmm, ok, my computer is really single user, so I have always launched my session before firing up nomachine. Maybe that is the critical difference.

No promises, but it might have been fixed in F22.

Gnome has been changing quite rapidly, and many changes do not make it back into older versions.

hmaarrfk gravatar imagehmaarrfk ( 2015-07-08 12:48:53 -0500 )edit

In a way, my question indirectly asks just that: has it been fixed in F22?

I didn't go with F22 initially because of all of the instability - I do want to get work done on this machine and it must be usable by others.

ArtND76 gravatar imageArtND76 ( 2015-07-08 13:08:57 -0500 )edit

Yea, I have the same problem and would just use KDE, it it didn't have a mouse issue. So, would someone from Gnome kindly fix the problem so Gnome doesn't crash if it doesn't see hardware acceleration?

Pretty please?

RogerP gravatar imageRogerP ( 2015-07-23 11:37:03 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-07-07 01:44:05 -0500

Seen: 228 times

Last updated: Jul 07 '15