Ask Your Question
1

Fix for Dell Inspiron 1545 Broadcom BCM4312

asked 2015-07-04 13:10:42 -0500

lindsaymacvean gravatar image

This is an update of sorts to this question here

https://ask.fedoraproject.org/en/question/9998/is-there-a-fedora-fix-for-the-dell-inspiron-1545-wireless-problem/

The wifi on this machine worked fine using the broadcom-wl package on fedora 20 Now upgraded to Fedora 22 and wifi no longer works

$lspci -knn | grep Broadcom 0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01) Subsystem: Dell Wireless 1397 WLAN Mini-Card [1028:000c] Kernel modules: wl

$modprobe wl -v insmod /lib/modules/4.0.4-301.fc22.x86_64/extra/wl/wl.ko modprobe: ERROR: could not insert 'wl': Operation not permitted

dmesg | grep wl [29.934107] wl: module license 'MIXED/Proprietary' taints kernel. [29.041554] wl: module verification failed: signature and/or required key missing - tainting kernel ...

I think it might be something to do with a secure module kernel parameter http://docs.fedoraproject.org/en-US/Fedora/22/html/System_Administrators_Guide/sect-kernel-module-authentication-requirements.html

But not sure how to disable this feature?

edit retag flag offensive close merge delete

Comments

That's a good question, and you've done a good job of researching it first. However, this question has been asked many times here: https://ask.fedoraproject.org/en/ques... and you may find what you need in one of the other posted questions. Good luck, and keep us informed.

sideburns gravatar imagesideburns ( 2015-07-04 15:12:49 -0500 )edit

Thankyou for pointing out that list. I still think my question has merit because the closest is https://ask.fedoraproject.org/en/ques... but that solution does not work for me because of the module verification I mentioned above. If someone could help me figure out how to disable module.sig_enforce then that might be the correct answer to this question.

lindsaymacvean gravatar imagelindsaymacvean ( 2015-07-04 16:21:25 -0500 )edit

Of course your question has merit; that's why I didn't close it. I don't have personal experience with that adapter, so I can't give you direct advice, so I thought I'd give you a pointer to a list of potential fixes.

sideburns gravatar imagesideburns ( 2015-07-04 18:36:39 -0500 )edit

from your message above show you are doing commands at the user command prompt "$". To run "akmod" commands or "modprobe" command reqire being login as a root user "#". To login as root you need to use the "su" command. which will ask for the root user password. then you will get the "#" command prompt. Also these command can have the command "sudo" command before each. Both will require the root password and allows root permissions to install the "akmod" and install the driver "wl" with the "modprobe" command. I hope this clears

MarkL gravatar imageMarkL ( 2015-07-05 23:39:10 -0500 )edit

Thanks @sideburns I really do appreciate it. @MarkL I did not know that about "$", because that computer has no working internet I actually had to painstakingly retype the error messages here :) so I think I actually was in root. Anyway I have now moved beyond the scope of this question although still dont have working wifi. (see my answer below)

lindsaymacvean gravatar imagelindsaymacvean ( 2015-07-06 06:57:07 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-07-06 07:13:31 -0500

lindsaymacvean gravatar image

updated 2015-07-06 07:45:20 -0500

So I partially solved this issue, by using the newer 4.0.6 kernel version of Fedora 22

Using uname -all I noticed that I was actually using the 4.0.4 kernel instead of the 4.0.6 kernel. (I dont know why my Fedora 22 upgrade defaulted to 4.0.4 when 4.0.6 was also available)

When I chose the newer kernel version for Fedora 22 at the boot loader I was able to get my USB working and use my phone hotspot to get internet, and modprobe wl now worked. The Wifi device now shows up on my NetworkManager however it is not able to detect any networks.

My next line of enquiry is to use the following question, although so far I have not completely solved this issue. https://ask.fedoraproject.org/en/ques...

UPDATE
I uninstalled kmod-wl akmod-wl then reinstalled both and followed the instructions in the question above:

  1. akmods --force(although it did not show Building and installing wl-kmodas mentioned in the other question`
  2. modprobe wl
  3. reboot
  4. the final touch for my Dell Inspiron 1545 was to hit ctrl + F2 and this activated manual wifi switch and wifi appeared :)
edit flag offensive delete link more

Comments

Thank you so much!!! I cannot express my gratitude for this life-saving answer. I was trying to get my wifi work for the past two days. Did researched a lot and tried a lot of commands but it didn't work out but yours did. Thanks again!!! I would like to take permission from you to post the link as well as the answer on my blog post. Can i post it. It would help many who are going through the same.

darkJedi gravatar imagedarkJedi ( 2016-11-24 05:49:41 -0500 )edit
0

answered 2017-05-20 05:16:49 -0500

Step 1. Install the broadcom-wl driver (broadcom-wl.noarch : Common files for Broadcom 802.11 STA driver) using sudo yum install broadcom-wl OR yum install broadcom-wl.

Step 2. Depending on your wireless card model, you might need to install b43 driver. Install using sudo yum install b43-fwcutter OR yum install b43-fwcutter.

Step 3. Reboot to the BIOS options, and deselect the Secure Boot if you haven't already. After login, the wireless should work on its own, but if not, go to a terminal and execute modprobe wl OR/AND modprobe b43 to recognize it. Hope this would help you. For more information check Dell Inspiron 1545 Manual.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-07-04 13:10:42 -0500

Seen: 1,567 times

Last updated: Jul 06 '15