Ask Your Question
0

Wordpress autoupdate

asked 2012-04-21 14:31:44 -0500

Daniel Standage gravatar image

I am trying to migrate my Wordpress blog from my Ubuntu box to a new Fedora 16 box. I was able to migrate all of the content, update URLs in the database, and everything was looking ok. Then I tried to run the autoupdate to get the latest version of Wordpress. This was the result.

Downloading update from http://wordpress.org/wordpress-3.3.2-partial-1.zip…

Download failed.: Failed to connect to 72.233.56.138: Permission denied

Installation Failed

The blog directory is owned by Apache and the permissions are set correctly, so I assume this is an SELinux issue. I have no experience with SELinux (nor do I understand its usefulness), but this is what I have to work with. I tried the following commands that I just learned a few hours ago...

chown -R apache /var/www/html/blog/
chcon -R -h -t httpd_sys_content_t /var/www/html/blog/
chcon -R -t httpd_sys_rw_content_t /var/www/html/blog/

...but that didn't change the autoupdate issue. Is this indeed an SELinux concern, and if so how can I fix it?

Thanks!

PS Looking at it a bit closer, it doesn't look like the problem is with the directories to which Wordpress is trying to download the update--rather, it looks like the problem is establishing the connection with the update server. Again, I can't think of any reason this wouldn't work other than SELinux.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2012-04-21 15:02:22 -0500

FranciscoD_ gravatar image

If it's an selinux issue, you can use 'sealert' to troubleshoot it. It's present in the setroubleshoot-server package.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-04-21 14:31:44 -0500

Seen: 299 times

Last updated: Apr 21 '12