Ask Your Question
0

Wifi not working after update

asked 2015-07-02 02:58:21 -0500

megh gravatar image

updated 2016-01-17 21:04:29 -0500

mether gravatar image

I updated the system yesterday after which the wifi is not working

Before I had installed kmod-wl which had installed broadcom-wl based on an answer on askfedora as initial installation had no wifi

This is my device 06:00.0 Network controller: Broadcom Corporation BCM43142 802.11b/g/n (rev 01) and I am on Fedora 22- Dell Inspiron 3543 i5

Please help.

edit retag flag offensive close merge delete

Comments

Perhaps the reason is that rpmfusion doesnot have kmod-wl for kernel 4.0.6 which was updated yesterday as it works fine in fedora with older kernel

megh gravatar imagemegh ( 2015-07-02 04:03:58 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-07-02 09:40:19 -0500

aeperezt gravatar image

Please install akmod that will get your broadcom-wl and update it agains new kernel and will not have that issue every time kernel update is done.

edit flag offensive delete link more

Comments

But does it increase boot time. I already have a 1 min 8s boot time on an 5th gen i5. Cant bear any longer

megh gravatar imagemegh ( 2015-07-02 10:59:19 -0500 )edit

Hum, it can be the first time since it has to get and compile the module. But after that should work as normal.

aeperezt gravatar imageaeperezt ( 2015-07-02 11:15:34 -0500 )edit

Okay thanks. I have to install only akmod or akmod-wl?

megh gravatar imagemegh ( 2015-07-02 11:44:57 -0500 )edit

do akmod-wl since that is what you need.

aeperezt gravatar imageaeperezt ( 2015-07-02 11:50:13 -0500 )edit

And should I remove kmod-wl and broadcom-wl?

megh gravatar imagemegh ( 2015-07-02 12:00:10 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-07-02 02:58:21 -0500

Seen: 864 times

Last updated: Jul 02 '15