Ask Your Question
1

Error using Steam with amd R9 390x on Fedora 22

asked 2015-06-27 00:03:43 -0500

Falcon2_0 gravatar image

updated 2015-10-17 22:33:42 -0500

mether gravatar image

The error is as follows:

$ steam
Running Steam on fedora 22 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: unable to load driver: radeonsi_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: radeonsi
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

and the process doesn't exit by it's self. You have to press Control-C.

edit retag flag offensive close merge delete

Comments

Just some minor analysis here. About the execution of the steam binary.

The main executable is a shell script that bootstraps ~/.steam/. Eventually ~/.steam/bin/steam will be executed.

 $ ldd bin/steam
linux-gate.so.1 (0xf77d4000)
libX11.so.6 => /lib/libX11.so.6 (0xf7277000)
librt.so.1 => /lib/librt.so.1 (0xf726e000)
libm.so.6 => /lib/libm.so.6 (0xf7220000)
libdl.so.2 => /lib/libdl.so.2 (0xf721b000)
libstdc++.so.6 => /lib/libstdc++.so.6 (0xf70a0000)
libpthread.so.0 => /lib/libpthread.so.0 (0xf7084000)
libc.so.6 => /lib/libc.so.6 (0xf6eb7000)
*(truncated)*

Nothing is missing.

NuuN gravatar imageNuuN ( 2015-06-27 09:06:16 -0500 )edit

It seems to be some deficiency in Mesa.

NuuN gravatar imageNuuN ( 2015-06-27 09:06:52 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-06-27 11:30:50 -0500

marcobassetto gravatar image

You have to launch steam using this:

LD_PRELOAD='/usr/$LIB/libstdc++.so.6' DIAPLAY=:0 steam

edit flag offensive delete link more

Comments

1

Correction:LD_PRELOAD="/lib/libstdc++.so.6" steam will run it in present session. Thanks for the solve!

NuuN gravatar imageNuuN ( 2015-06-27 12:14:38 -0500 )edit

Didn't work for me: I get LD_PRELOAD="/lib/libstdc++.so.6" steam ERROR: ld.so: object '/lib/libstdc++.so.6' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.

Sika56 gravatar imageSika56 ( 2016-09-04 07:10:38 -0500 )edit
0

answered 2015-06-27 22:49:23 -0500

shadowhh32 gravatar image

you mean DISPLAY=:0 ? You can script kiddie this if you like and just run the script.

edit flag offensive delete link more

Comments

Documentation puts GDM running on :0 always. The user sessions start at :1.

NuuN gravatar imageNuuN ( 2015-06-28 11:44:54 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-06-27 00:03:43 -0500

Seen: 2,037 times

Last updated: Jun 27 '15