Ask Your Question
1

Fedora 22 will not boot after installation (VM)

asked 2015-06-25 10:17:23 -0500

mmalina gravatar image

updated 2015-06-25 22:50:25 -0500

mether gravatar image

After installing Fedora 22 in a VM, it will not boot. It will show grub, then starts booting, the Fedora icon appears, shows some loading, then flashes and that's it - from then on, there is no activity.

When I changed the grub settings to remove "rhgb" it, I will see the boot progress up until: [ OK ] Started User Manager for UID 42... See a screenshot here: https://www.dropbox.com/s/n385jlohqx4...

This is on a VM via libvirt (installed using virt manager) on a RHEL 6.6 machine. BTW, the virt-manager didn't offer Fedora 22 as the OS type, so I used Fedora 21.

Any help in troubleshooting this is appreciated.

edit retag flag offensive close merge delete

Comments

i guess this will solve: "su -" "nano /etc/gdm/custom.conf" remove the "#" in the line "#waylandEnable = false" save with ctrl+O reboot

George S.C.C gravatar imageGeorge S.C.C ( 2015-08-03 00:07:53 -0500 )edit

I am also having this problem. I installed Fedora 22 into a XEN HVM under a Fedora 21 host and it hangs on boot. If I don't touch the keyboard then it hangs with the fedora logo shown, if I press ESC during bootup then it shows the text and either ends with "Started User Manager for UID 42." or sometimes "Started Virtualisation daemon.".

I have tried George's suggestion (I had to mount the VM's LV as a PV using "kpartx -a /dev/pvname/lvname" then mount the internal LV - incidentally the default filesystem for Fedora 22 now appears to be XFS). This had no effect and bootup still hangs.

grahamc gravatar imagegrahamc ( 2015-10-17 23:53:59 -0500 )edit

Thanks a lot

Subhroneel gravatar imageSubhroneel ( 2016-08-19 08:01:52 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-10-21 06:34:15 -0500

grahamc gravatar image

updated 2015-10-21 06:37:28 -0500

Step 1 - At the grub boot menu, press 'e' to edit the bootup settings.

Step 2 - go down to the line starting with "linux16 /vmlinuz" (it will probably span multiple lines) and add a " 3" to the end (that is a space, then a '3'). This will tell the bootup scripts to load only the text console, and not attempt to start a graphical login screen.

Step 3 - Press CTRL-X to bootup.

Step 4 - login as root.

Step 5 - "vi /etc/gdm/custom.conf" (or use your editor preference instead of vi), and delete the leading "#" from the line "#WaylandEnable=false". Save the file.

Step 6 - Reboot and enjoy :)

Note that I have heard that replacing step 5 with "dnf update" will also fix the issue (and update the rest of the system in the process). This would be preferable to just updating the file as per the above, but you can always follow my instructions and then run an update once you are able to graphically login.

Note 2 that if you edit custom.conf from the host (using kpartx to access the filesystem as per my comment to the original post) then you will break the selinux permissions and you will end up with the same symptoms (bootup stalls with fedora logo). If you have done this, then you can use my instructions (Steps 1 through 4 above) to boot into text mode and fix the permissions by running "restorecon -R -v /etc". It should then bootup properly.

edit flag offensive delete link more

Comments

Thanks a lot, this worked for me!

mmalina gravatar imagemmalina ( 2015-11-05 10:25:21 -0500 )edit

I created a new account just to thank you

ffleader1 gravatar imageffleader1 ( 2016-06-06 10:22:16 -0500 )edit

This is still an issue with Fedora 24. I have raised a bug for this at https://bugzilla.redhat.com/show_bug....

grahamc gravatar imagegrahamc ( 2016-07-06 06:01:55 -0500 )edit

Saved my laptop -- thanks a lot!

rod lee gravatar imagerod lee ( 2016-09-03 07:19:50 -0500 )edit

Solved 'Stopped User Manager for UID 1000" loop for me after upgrade Fedora 23 VirtualBox Guest (VB 5.1.8). Out commenting 'WaylandEnable=false' alone did the trick. Tysm

nippur gravatar imagenippur ( 2016-11-03 09:32:59 -0500 )edit
0

answered 2015-10-21 16:13:49 -0500

I tried running dnf update from command line after I log in as root and still ran into the same issue, but once I commented out WaylandEnable everything worked. Thanks!

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-06-25 10:17:23 -0500

Seen: 8,738 times

Last updated: Oct 21 '15