Ask Your Question

Cannot logout user

asked 2015-06-18 09:33:11 -0500

cor gravatar image

updated 2015-06-20 23:22:56 -0500

mether gravatar image

I tried to choose the Wayland gnome desktop on a good running f21. at next boot comp was extremely slow and I could not switch user or logout a special user. the system simply boots simply to the last user before the problem begun. No login screen. In terminal window you cannot see text. Help

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2015-06-18 10:10:53 -0500

BRPocock gravatar image

updated 2015-06-18 13:04:39 -0500

To forcibly log out a user, from another terminal or console (you can always reach a text console with Control+Alt+F6 — and usually also with Control+Alt+[F2…F12], but F6 is guaranteed to work), you can run

 sudo killall -u username

or, to be more “forceful” and not allow processes to protest:

 sudo killall -KILL -u username

(It's usually the case that just hitting Control+Alt+Backspace will also kill the graphical desktop session, but I don't recall if that is enabled by default on Fedora.)

If Wayland isn't working with your video system yet, you might try

 sudo dnf remove wayland

(You could also use sudo yum remove wayland if you don't have dnf installed yet on your Fedora 21 system.)

If the normal Gnome Terminal is having issues, the older (uglier but more stand-alone) xterm program is available — sudo dnf install xterm will install it (or find it in Software Center), and you can start it from the Gnome Activities Overview (Super/Activities key + xterm + Return) or the (somewhat hidden) “Run Program” window (default: Alt+F2 on the desktop, then type xterm + Return).

The Terminal's font defaults to the system's monospace font, but can be overridden in the Terminal itself; check Edit → Profile Preferences → General tab→ □ Custom Font. To change the system-wide default monospace font, you can install gnome-tweak-tool (via dnf or yum or “Software”) and edit the fonts (with some care — the Tweak tool is a bit more “dangerous” than “Settings”).

If a certain user is being logged in automatically, go to Settings (from the top-right menu) → Users, and then click Unlock; find that user in the list at the left, and switch “Automatic Login” to “Off.”

If you have some strange problems like this after installing new packages, running

  sudo dnf repoquery --unsatisfied

… may reveal some missing packages; or sudo rpm --verify --all will show any files that have been changed since thef were installed. (Files listed with a c to the left of their names are configuration files; other files that have changed are somewhat suspicious.) If you suspect a package is broken (eg, files deleted or altered), you can find the package providing a file with rpm -qf /path/to/file and sudo dnf reinstall package-name.

edit flag offensive delete link more

Question Tools


Asked: 2015-06-18 09:33:11 -0500

Seen: 688 times

Last updated: Jun 18 '15