Ask Your Question

Unable to use HP network scanner

asked 2015-06-17 10:29:46 -0500

luya gravatar image

updated 2015-06-25 22:52:17 -0500

mether gravatar image

HP all-in-one printer Photosmart eStation was correctly detected in the network and can be used for print. Unfortunately, any scanner application does not. Is there a solution to fix that problem using Gnome settings?

edit retag flag offensive close merge delete


Does that scanner has a web interface, my Photosmart has one that allow me to scan, it is not the best solution but works specially since I don't want to connect to it with the USB cable

aeperezt gravatar imageaeperezt ( 2015-06-17 10:33:29 -0500 )edit

Yes it does have a web interface. Although I know the ip, I tried to figured a permanent solution for that problem.

luya gravatar imageluya ( 2015-06-17 10:41:53 -0500 )edit

if you have a linux machine connected to the scanner try sane and dnf install sane-frontends xsane this has a good documentation on it but not figured out how to work over the network

aeperezt gravatar imageaeperezt ( 2015-06-17 10:57:39 -0500 )edit

I posted the suggestion. BRPocock's solution is also good due to reason below.

luya gravatar imageluya ( 2015-06-19 00:56:38 -0500 )edit

4 Answers

Sort by » oldest newest most voted

answered 2015-06-17 11:02:03 -0500

BRPocock gravatar image

Most HP all-in-one scanners are supported by package hplip-gui (pkcon install hplip-gui) — which installs the “HP Device Manager” application. This could/should enable configuring your scanner. Once it's enabled, a program like simple-scan or xsane should be able to draw from it.

edit flag offensive delete link more


That step can be optional when running from the terminal using hp-setup command

luya gravatar imageluya ( 2015-06-17 11:57:27 -0500 )edit

answered 2015-06-17 11:51:53 -0500

luya gravatar image

I figured out the problem. The correct device location should start with hp:/net rather than dnssd. It is like hp:/net/devicename/zc=hostname where devicename is self-explanatory and the hostname is the host as listed from the web interface. The full name can be detected using hp-setup hostname. For example, my device listed as hp:/net/Photosmart_eStn_C510_series/zc=HPFFCB9

If you are using ip address instead, replace zc=hostname by ip="ip address".

I just remember I filed that report a while ago and had a solution link text. The bug is from upstream hplip. Anyone having a network HP all-in-one printer should try that workaround and make sure to restart cups (sudo systemctl restart cups) or simply reboot. Also read the rationale behind the issue.

edit flag offensive delete link more

answered 2019-01-23 02:22:27 -0500

After installing the required libs and hplip-gui and adding printer, the scan still didn't work. I fixed the scan issue with the below:

Open settings > Printers > Gear Icon > Printer Details

Then click on localhost

The CUPs local setup page will open in browser, Follow steps to add the printer then re-open simple-scan and try scan

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2015-06-17 10:29:46 -0500

Seen: 4,786 times

Last updated: Jun 17 '15