Ask Your Question
1

Fedora upgrade 21 to 22 - requires freerdp-libs-1.2.0-0.9.git.24a752a.fc22.x86_64

asked 2015-06-16 16:10:40 -0500

Samurai gravatar image

Trying to upgrade from 21 to 22.
Did a yum update, disabled all the repos except from fedora and updates and then ran the following:

# rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-22-$(uname -i)
# yum update yum
# yum clean all
# yum --releasever=22 distro-sync

Which throws some errors which VLC requires a different version of freerdp-libs.

Tried the last one with --skip-broken which throws me other errors. Tried downloading and installing the required rpm, but failed. Would appreciate any help.

--> Finished Dependency Resolution
Error: Package: vlc-core-2.2.1-5.fc21.x86_64 (@rpmfusion-free-updates/21)
           Requires: libfreerdp-codec.so.1.2()(64bit)
           Removing: 1:freerdp-libs-1.2.0-0.6.beta.1.fc21.2.x86_64 (@updates/21)
               libfreerdp-codec.so.1.2()(64bit)
           Updated By: 2:freerdp-libs-1.2.0-0.9.git.24a752a.fc22.x86_64 (fedora)
               Not found
Error: Package: vlc-core-2.2.1-5.fc21.x86_64 (@rpmfusion-free-updates/21)
           Requires: libfreerdp-rail.so.1.2()(64bit)
           Removing: 1:freerdp-libs-1.2.0-0.6.beta.1.fc21.2.x86_64 (@updates/21)
               libfreerdp-rail.so.1.2()(64bit)
           Updated By: 2:freerdp-libs-1.2.0-0.9.git.24a752a.fc22.x86_64 (fedora)
               Not found
Error: Package: vlc-core-2.2.1-5.fc21.x86_64 (@rpmfusion-free-updates/21)
           Requires: libfreerdp-locale.so.1.2()(64bit)
           Removing: 1:freerdp-libs-1.2.0-0.6.beta.1.fc21.2.x86_64 (@updates/21)
               libfreerdp-locale.so.1.2()(64bit)
           Updated By: 2:freerdp-libs-1.2.0-0.9.git.24a752a.fc22.x86_64 (fedora)
               Not found
Error: Package: vlc-core-2.2.1-5.fc21.x86_64 (@rpmfusion-free-updates/21)
           Requires: libfreerdp-core.so.1.2()(64bit)
           Removing: 1:freerdp-libs-1.2.0-0.6.beta.1.fc21.2.x86_64 (@updates/21)
               libfreerdp-core.so.1.2()(64bit)
           Updated By: 2:freerdp-libs-1.2.0-0.9.git.24a752a.fc22.x86_64 (fedora)
               Not found
Error: Package: vlc-core-2.2.1-5.fc21.x86_64 (@rpmfusion-free-updates/21)
           Requires: libfreerdp-crypto.so.1.2()(64bit)
           Removing: 1:freerdp-libs-1.2.0-0.6.beta.1.fc21.2.x86_64 (@updates/21)
               libfreerdp-crypto.so.1.2()(64bit)
           Updated By: 2:freerdp-libs-1.2.0-0.9.git.24a752a.fc22.x86_64 (fedora)
               Not found
Error: Package: vlc-core-2.2.1-5.fc21.x86_64 (@rpmfusion-free-updates/21)
           Requires: libfreerdp-gdi.so.1.2()(64bit)
           Removing: 1:freerdp-libs-1.2.0-0.6.beta.1.fc21.2.x86_64 (@updates/21)
               libfreerdp-gdi.so.1.2()(64bit)
           Updated By: 2:freerdp-libs-1.2.0-0.9.git.24a752a.fc22.x86_64 (fedora)
               Not found
Error: Package: vlc-core-2.2.1-5.fc21.x86_64 (@rpmfusion-free-updates/21)
           Requires: libfreerdp-primitives.so.1.2()(64bit)
           Removing: 1:freerdp-libs-1.2.0-0.6.beta.1.fc21.2.x86_64 (@updates/21)
               libfreerdp-primitives.so.1.2()(64bit)
           Updated By: 2:freerdp-libs-1.2.0-0.9.git.24a752a.fc22.x86_64 (fedora)
               Not found
Error: Package: vlc-core-2.2.1-5.fc21.x86_64 (@rpmfusion-free-updates/21)
           Requires: libfreerdp-utils.so.1.2()(64bit)
           Removing: 1:freerdp-libs-1.2.0-0.6.beta.1.fc21.2.x86_64 (@updates/21)
               libfreerdp-utils.so.1.2()(64bit)
           Updated By: 2:freerdp-libs-1.2.0-0.9.git.24a752a.fc22.x86_64 (fedora)
               Not found
Error: Package: vlc-core-2.2.1-5.fc21.x86_64 (@rpmfusion-free-updates/21)
           Requires: libfreerdp-common.so.1.2.0()(64bit)
           Removing: 1:freerdp-libs-1.2.0-0.6.beta.1.fc21.2.x86_64 (@updates/21)
               libfreerdp-common.so.1.2.0()(64bit)
           Updated By: 2:freerdp-libs-1.2.0-0.9 ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2015-06-16 18:50:04 -0500

My recommendation is to uninstall the VLC, upgrade and then install VLC again.

edit flag offensive delete link more
0

answered 2015-07-15 23:48:36 -0500

Please do the below step

  1. # yum clean all 2.# yum-config-manager --disable rpmfusion-free-updates 3.# yum install vlc
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-06-16 16:10:40 -0500

Seen: 579 times

Last updated: Jun 16 '15