Ask Your Question
2

How to get Nautilus to see Windows Shares?

asked 2015-06-15 20:21:05 -0500

MarkL gravatar image

updated 2015-06-16 17:53:58 -0500

My problem is a mystery to me. I have a Win XP computer with a shared directory. I have a Dell E5500 which is a dual boot from Win 7 and Fedora 21. If I boot into Fedora 21 I am unable to access the Win XP shares. When I go to Windows networks I can see the work group. But get an error message "Unable to access location." If I boot into the Win 7 i can see all Windows shares on all computers. If I then reboot back into the Fedora 21 and go to Nautilus and browse the network I see all Windows shares and Linux shares. If go to windows network I can see the work group. I am able to see all computers with windows shares in the work group. I am able to access those computers to see shares on those computers. If I reboot back into Fedora 21 I am back to not being able to access windows shares. I can not figure out where Fedora is pickling up the list of windows shares that can only be found after rebooting from windows? Can anyone help me with this mystery?

edit retag flag offensive close merge delete

Comments

1

Do you perhaps have a firewall rule blocking the nmb service? (This is the “browser” directory for Windows-for-Workgroups-type sharing; ie, finding “local” machines; it's distinct from the DNS-based “directory” service if you're signed into an Active Directory domain.)

BRPocock gravatar imageBRPocock ( 2015-06-16 12:53:21 -0500 )edit

I have try turning the firewall completely off and have the same problem. I just have a work-group not an active directory in a domain. There has to be a place nmb service is to look for windows shares. I am just not as adept with Fedora and Linux to figure it out. Thanks for your suggestions.

MarkL gravatar imageMarkL ( 2015-06-16 18:03:25 -0500 )edit

Well, BRPocock you made me do a little thinking. So I tested the service to see if it is working. Here is what got. Look like the nmb service is disabled and I need to get it activated. Here is how I found out.

service nmb status

Redirecting to /bin/systemctl status nmb.service ● nmb.service - Samba NMB Daemon Loaded: loaded (/usr/lib/systemd/system/nmb.service; disabled) Active: inactive (dead)

MarkL gravatar imageMarkL ( 2015-06-16 18:33:36 -0500 )edit

@MarkL: Run systemctl start nmb to start nmb

florian gravatar imageflorian ( 2015-06-16 20:26:58 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-06-16 10:08:22 -0500

florian gravatar image

updated 2015-06-16 10:11:16 -0500

I can't explain what's going on and I am also not surprised but may I suggest you a little workaround?

Once you see the the shares on the smb network bookmark it in Nautilus (Bookmark this location) and you should be good to go in the future.

Browsing smb/cifs Windows network shares has always been a problem for me, so that's how I work around it.

And if you want to be permanently connected to the share(s) you can also tell your Linux system to mount the at start up. There is a similar Q/A here.

Good luck!

edit flag offensive delete link more

Comments

Florian, I will try that Florian. Thank you for your help. Best Regards, MarkL

MarkL gravatar imageMarkL ( 2015-06-16 17:45:44 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-06-15 20:21:05 -0500

Seen: 2,208 times

Last updated: Jun 16 '15