Ask Your Question
1

F22: graphics driver not loaded?

asked 2015-06-14 05:36:17 -0500

E335 gravatar image

updated 2015-06-20 23:21:08 -0500

mether gravatar image

Since update via fedup from F21 to F22 I face an issue with the Laptop display. When booting the screen is grey. The boot works normal what I see because I attached an external monitor and after entering the user and password (blindly) I can work normally in F22 on the external monitor. The internal stays grey (not black, some light seems to ne there, but no graphics or letters at all). There is no hardware defect because the display works fine when I start F22 with the old kernel 3.xxxx

Please advise what the issue might be. Thank you!

Hardware: Lenovo Thinkpad E335

System information: [user@linux-2 ~]$ uname -a Linux linux-2.fritz.box 4.0.4-303.fc22.x86_64 x86_64 x86_64 x86_64 GNU/Linux

Graphics driver: @linux-2 ~]$ lspci -nnk |grep -i -A3 vga 00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 7340] [1002:9808] Subsystem: Lenovo Device [17aa:5104] Kernel driver in use: radeon Kernel modules: radeon

edit retag flag offensive close merge delete

Comments

I bumped into the same issue. Seems to be related to kernel 3.xxx -> 4.0.4 (update to 4.0.5 doesn't solve it). Under F21, I had to downgrade to 3.xxx, but I couldn't do the same for F22 for it seems there is no official kernel package with version 3.xxx.

I tried F22 on different computers (desktop, laptop, virtual machines, all with different hardware) and the result was the same: no video output on main screen. I did not test with an external monitor, though.

Help needed since this prevents my F21->F22 upgrade.

ajlittoz gravatar imageajlittoz ( 2015-06-14 13:32:27 -0500 )edit

I'm not sure if Fedora compiles radeon into the kernel or not (I don't have one), so I'm going to guess that it doesn't. Boot the old kernel and run lsmod. Do you see the radeon driver loaded? Do the same with the new kernel. Also, is there anything interesting in journalctl?

bthomas gravatar imagebthomas ( 2015-06-14 16:05:20 -0500 )edit

My laptop has indeed a Radeon HD 7310 video card but my desktop has an nVidia GTX something and both show the same behaviour. Moreover virtual machines have emulated basic video cards and give same result!

ajlittoz gravatar imageajlittoz ( 2015-06-15 11:20:20 -0500 )edit

@bthomas. Will check at weekend, I'm travelling so I cannot check with the new kernel without external monitor .... Thanks for suggestion, will come back on this!

E335 gravatar imageE335 ( 2015-06-15 12:51:57 -0500 )edit

THis is output from lsmod first for the 4.xxx kernel and then for the 3.xxx

4er kernel

Module Size Used by radeon 1556480 7 i2c_algo_bit 16384 1 radeon drm_kms_helper 118784 1 radeon ttm 94208 1 radeon drm 331776 10 ttm,drm_kms_helper,radeon

3er kernel

Module Size Used by radeon 1560256 7 i2c_algo_bit 13250 1 radeon drm_kms_helper 111166 1 radeon ttm 92999 1 radeon drm 313580 10 ttm,drm_kms_helper,radeo

E335 gravatar imageE335 ( 2015-06-21 03:43:36 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-06-22 13:48:46 -0500

I had a similar problem after FedUping from 21 to 22.

Following @bthomas's suggestions, I found this on journalctl:

[drm:radeon_init [radeon]] *ERROR* No UMS support in radeon module!

I ran lsmod and found that radeon was not loaded.

Searching on, I came upon a suggestion to remove nomodeset from the kernel arguments in the GRUB menu. Didn't work for me. But when I replaced nomodeset with radeon.modeset=0 everything suddenly fell in place!

Now I'm trying to figure out how to permanently change grub.cfg...

edit flag offensive delete link more

Comments

Thanks the radeon.modeset=0 worked for me :) . In the grub.cfg I don't find anything like 'nomodeset' ..... so if you succeed I'd appreciate if you share here again.

E335 gravatar imageE335 ( 2015-06-22 17:30:36 -0500 )edit

I used Engineering Walden's suggestion: Modified /etc/default/grub (radeon.modeset=0 instead of nomodeset) and saved, then grub2-mkconfig -o /boot/grub2/grub.cfg (since I don't use EFI).

From what I understand, this will only last until the next time GRUB or the kernel will be auto-updated and be overridden by default definitions, but at least I don't have to make the change every time I boot...

omerori gravatar imageomerori ( 2015-06-23 06:06:33 -0500 )edit

@omerori you have the method right, and it is persistent. grub2-mkconfig completely recreates the grub config using the template in /etc/default.grub so by using it you proved that your method makes persistent changes.

randomuser gravatar imagerandomuser ( 2015-06-23 08:54:43 -0500 )edit

It worked for me too on my laptop. My desktop has an nVidia video card. Have you any idea how I could fix the problem? Something like nouveau.modeset=0?

ajlittoz gravatar imageajlittoz ( 2015-06-23 10:08:09 -0500 )edit

The etc/default/grub looks like this, nothing like nomodeset, please advsie: GRUB_CMDLINE_LINUX="vconsole.font=latarcyrheb-sun16 $([ -x /usr/sbin/rhcrashkernel-param ] && /usr/sbin/rhcrashkernel-param || :) rhgb quiet"

E335 gravatar imageE335 ( 2015-06-23 16:45:02 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-06-14 05:27:11 -0500

Seen: 1,376 times

Last updated: Jun 14 '15