Ask Your Question
3

Auto Login with Gnome Keyring

asked 2011-12-18 11:18:49 -0500

dmachop gravatar image

Is it possible to autologin the Gnome-Keyring(Seahorse) along with the User Account?

edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted
4

answered 2013-02-12 15:54:30 -0500

bigben87 gravatar image

Yes, there is a way to use autologin and have the login keyring unlocked automatically: Set an empty password. In seahorse, click view and enable By Keyring, then in the left column under Passwords on Login right click and select Change Password.

edit flag offensive delete link more
2

answered 2011-12-19 03:13:30 -0500

grawity gravatar image

Your keyrings are locked with your login password. When you use automatic login, the system logs you in without asking for a password, therefore it cannot unlock the keyring automatically.

If you want, you can remove the keyring's password entirely (change to a blank one) through seahorse, this way the keyring and all its contents will be stored in plain text on disk.

edit flag offensive delete link more
0

answered 2011-12-18 21:46:36 -0500

ryran gravatar image

updated 2011-12-18 21:47:24 -0500

I'm not sure I understand you properly at all. Let me try... You want to make it so that as soon as you log in, you get prompted to unlock your GPG private key, via Seahorse? If so, and you're on the latest version of Fedora, it's as simple as trying to decrypt a file; when you get prompted for your passphrase, you can click on "Details" and select "Automatically unlock this keyring whenever I'm logged in"

See attached screenshot: seahorse_dialogF16.png

edit flag offensive delete link more
0

answered 2011-12-18 12:09:01 -0500

The IceMan Blog gravatar image

updated 2011-12-18 12:10:22 -0500

These are the lines you need in your /etc/gdm/custom.conf ([daemon] section) to make auto-login work. It only auto-logs in on first boot, and it must be a non-root user.

AutomaticLoginEnable=true
AutomaticLogin=whatever_username
edit flag offensive delete link more
-1

answered 2012-06-10 15:03:58 -0500

andreavatar gravatar image

updated 2012-06-10 15:07:38 -0500

Hi all, I have the same problem of dmachop, tried before to insert into [daemon] section of custom.conf the lines of autologin but these caused the block of my pc, and I was forced to start in recovery mode using editor vi, cause I am a root user, how can I autologin ?

edit flag offensive delete link more

Comments

Ask a new question! Do not put the question as an answer to another question.

erik gravatar imageerik ( 2013-03-09 05:47:13 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2011-12-18 11:18:49 -0500

Seen: 13,669 times

Last updated: Feb 12 '13