Ask Your Question

Broadcom 4352 Wifi Issue on Fedora 22 [Latest Kernel]

asked 2015-06-09 13:27:15 -0500

cynicofsinope gravatar image

updated 2015-06-10 19:38:18 -0500

mether gravatar image

I'm new to Linux, switching from windows, and it has been great so far, except for one small issue.

I'm pretty sure that this has been asked multiple tines, but none of the solutions seems to work, I am probably doing something wrong.

Anyway, I installed the latest kernel update for Fedora 22 and I can not see any options for connecting to a wireless network in the network manager. I know its an issue with my Broadcom 4352 wireless card. The funny thing though, is that my Bluetooth works completely fine.

I tried the installing ak-mod wl and k-mod solutions route, however that didn't seem to fix anything, once again odds are I did something wrong.

Could anyone help me, please? Id really love to continue using Fedora, but this is such a limiting factor.

Thanks for any and all help.

edit retag flag offensive close merge delete


If your computer has UEFI try it by disabling secure boot to see if that works, if it does you need a signed driver, to work with UEFI enabled

aeperezt gravatar imageaeperezt ( 2015-06-09 14:18:55 -0500 )edit

I actually had secure boot disabled when I installed Fedora, and I still have it disabled currently. I made sure that it was disabled. What do you think?

cynicofsinope gravatar imagecynicofsinope ( 2015-06-09 15:33:28 -0500 )edit

Have to asume you try drivers, if they do not work then you need to download drivers from broadcom and compile your self, it had work for me before with broadcom drivers if you need to know how to do that let me know.

aeperezt gravatar imageaeperezt ( 2015-06-09 21:00:47 -0500 )edit

OK, I'll try that, can you tell me what I need to do?

cynicofsinope gravatar imagecynicofsinope ( 2015-06-10 11:11:16 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2015-06-10 21:26:26 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

OK, I figured out what's going on, the issues with wifi come from the fact that both kmod-wl and akmod-wl rpm packages are currently not supporting the latest kernel release for Fedora 22.

Everyone who is having issues need to check their kernel versions and make sure that they are using the current kernel until RPMFusion releases updated packages that support the latest kernel.

So here is a reference for others:

1-Open a terminal on your computer

2-Gain root access in your terminal: - Type su into your terminal and it will ask you to enter your password.

3-Type: rpm -q kernel -This command will list the kernal you have installed -Here is some sample output:

        # rpm -q kernel 

The kernel that will absolutely not work with kmod-wl. akmod-wl, broadcom-wl, or any other braodcom wireless drivers is: kernel-4.0.4-303.fc22.x86_64.

kmod-wl. akmod-wl, broadcom-wl, b43-fscutter, and other broadcom wireless drivers, currently only support this kernel: kernel-4.0.4-301.fc22.x86_64.

TL:DR: You have to be running: kernel-4.0.4-301.fc22.x86_64 on Fedora 22 for kmod-wl. akmod-wl, broadcom-wl, or any other braodcom wireless drivers to work.

edit flag offensive delete link more

Question Tools


Asked: 2015-06-09 13:27:15 -0500

Seen: 3,590 times

Last updated: Jun 10 '15