Ask Your Question
1

How to install Bumblebee with NVIDIA drivers for hybrid GPU?

asked 2015-06-09 04:42:34 -0500

Steven Roose gravatar image

updated 2015-06-15 11:32:19 -0500

I initially posed the question below, but the answers explains how to install the correct drivers, so I updated the question title. The instructions on the Bumblebee Wiki page do not work for F22.


I tried to install Nvidia drivers and Bumblebee for my Nvidia GeForce GTX 860M GPU. I had to force shutdown (power button) for some reason, and after booting back up, I got a blank black screen after the teardrop screen several tries.

I went into terminal (ctrl-alt-F2) and did sudo yum remove bumblebee* nvidia* akmod-nvidia*, the three things I had installed (Bumblebee wiki page on Fedora wiki).

But the problem was not solved. I took a screenshot from the terminal during the teardrop boot (by pressing Esc) : It stops at Starting Terminate Plymouth bootscreen....

Can anyone help? My computer is unusable now... (Installation was the new Fedora 22 KDE spin.)

Ok the file upload doesn't seem to work on mobile, here is a link: https://docs.google.com/file/d/0B4MSn...

edit retag flag offensive close merge delete

Comments

Noticing this only as I check the photo on an older PC, my screen is filthy. You don't really notice that when you are using it.

Steven Roose gravatar imageSteven Roose ( 2015-06-09 06:01:03 -0500 )edit

mmm, maybe a problem with wayland, why no try change gdm to lightdm?

davidva gravatar imagedavidva ( 2015-06-09 19:53:44 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-06-10 20:51:30 -0500

bthomas gravatar image

updated 2015-06-15 11:48:15 -0500

"Lets consider the actual problem with the NVIDIA drivers is out of the scope of this question." Nah. You have a great graphics card just weighing down your laptop. So try installing it with this instead:

$ dnf install libbsd-devel libbsd glibc-devel libX11-devel help2man autoconf git tar glib2 glib2-devel kernel-devel kernel-headers automake gcc gtk2-devel
$ dnf install VirtualGL
$ dnf install http://install.linux.ncsu.edu/pub/yum/itecs/public/bumblebee/fedora22/noarch/bumblebee-release-1.2-1.noarch.rpm
$ dnf install http://install.linux.ncsu.edu/pub/yum/itecs/public/bumblebee-nonfree/fedora22/noarch/bumblebee-nonfree-release-1.2-1.noarch.rpm
$ dnf install bbswitch bumblebee-nvidia

Restart, and now you can test it with:

$ glxgears -info | grep GL_VENDOR
# Should be claiming to be using Intel.
$ optirun glxgears -info | grep GL_VENDOR
# Should be claiming to be using NVidia. Success.

EDIT: The bug is fixed in Fedora 22 with the latest upgrade, so please do so and ignore the rest.

There seems to be a bug (that seems to be fixed upstream) that makes SELinux stop optirun from running, so in order to use optirun you'll need to temporarily put SELinux into permissive mode.

# If you can't use vi, use gedit.
$ sudo vi /etc/selinux/config

And change SELINUX=enforcing to SELINUX=permissive. Save, and restart your machine.

If you care about SELinux, change it to enforcing and restart when your done.

edit flag offensive delete link more

Comments

Thanks for the answer. I have general problems shutting down and booting up as well, so I'm first gonna gather some info on that, so that I can provide better info to the devs. I'll try installing tonight.

Steven Roose gravatar imageSteven Roose ( 2015-06-12 12:02:27 -0500 )edit

The steps you mention, they only install Bumblebee, right? Not the NVIDIA drivers? Because there is an issue with the NVIDIA drivers from RPMfusion on KDE, they don't work. (I'm not the only one with this problem.)

Steven Roose gravatar imageSteven Roose ( 2015-06-12 17:12:17 -0500 )edit

The steps I mentioned install the NVidia drivers from elsewhere (implicitly, don't install the rpmfusion drivers) as well as bumblebee, and will make most NVidia Optimus laptops work with a fresh Feodra 22 install (bleeding edge laptops might need to wait a few months). The rpmf NVidia drivers assume that NVidia is the only graphics available on the machine and tries to pipe the graphics out the NVidia card. However, in optimus systems the intel GPU is responsible for piping out graphics even when NVidia is in use. So the default rpmf drivers wouldn't work with any DE with optimus.

bthomas gravatar imagebthomas ( 2015-06-12 17:46:44 -0500 )edit

Sidenote: you might be able to adjust the rpmfusion drivers or the raw drivers from the NVidia site and edit the XOrg config yourself (I did this on Arch Linux and Gentoo) to get it working properly. But someone's already done the work, and it's really not that interesting.

bthomas gravatar imagebthomas ( 2015-06-12 17:49:14 -0500 )edit

I can't edit your answer (I guess too little karma), but it should be glxgreas -info. It worked btw, so many many thanks!

Steven Roose gravatar imageSteven Roose ( 2015-06-15 11:26:45 -0500 )edit
0

answered 2015-06-09 17:29:10 -0500

Steven Roose gravatar image

Ended up using dnf history and dnf history rollback to roll back to what it was before the issue.

Lets consider the actual problem with the NVIDIA drivers is out of the scope of this question.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-06-09 04:42:34 -0500

Seen: 11,226 times

Last updated: Jun 15 '15