Ask Your Question
0

WIFI not showing after update

asked 2015-06-09 01:41:12 -0500

Ujitha gravatar image

I'm using lenovo G510 Laptop with Fedora 22 I have update the fedora recently now my WiFi is not showing. Please kind enough to help me.

lspci -nn | grep Network :- 02:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)

rpm -qa | grep broadcom :- broadcom-wl-6.30.223.248-2.fc22.noarch

package rpmfusion-free-release-22-1.noarch (which is newer than rpmfusion-free-release-20-1.noarch) is already installed package rpmfusion-nonfree-release-22-1.noarch (which is newer than rpmfusion-nonfree-release-20-1.noarch) is already installed

yum install kmod-wl :- Package kmod-wl-6.30.223.248-8.fc22.1.x86_64 is already installed

yum install ndiswrapper :- Package ndiswrapper-1.59-1.fc22.x86_64 is already installed

yum install broadcom-wl :- Package broadcom-wl-6.30.223.248-2.fc22.noarch is already installed

uname -r :- 4.0.4-303.fc22.x86_64

rpm -q kmod-wl :- kmod-wl-6.30.223.248-8.fc22.1.x86_64

edit retag flag offensive close merge delete

Comments

is the module loaded ? lsmod | grep wl

baoboa gravatar imagebaoboa ( 2015-06-09 04:10:57 -0500 )edit

No. Not loaded

Ujitha gravatar imageUjitha ( 2015-06-09 05:17:56 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2015-06-09 12:26:06 -0500

baoboa gravatar image

updated 2015-06-11 10:54:18 -0500

you should have this package installed kmod-wl-4.0.4-303.fc22.x86_64.x86_64 , which doesn't exist yet

install the akmod to build it

dnf install akmod-wl kernel-devel kernel

to build for a specific kernel

akmods --force --kernels 4.0.4-303.fc22.x86_64

normally kmods are re-built at boot time

edit flag offensive delete link more

Comments

Package akmod-wl-6.30.223.248-8.fc22.1.x86_64 is already installed Package gcc-5.1.1-1.fc22.x86_64 is already installed, skipping. Package make-1:4.0-3.1.fc22.x86_64 is already installed, skipping. Package kernel-devel-3.19.7-200.fc21.x86_64 is already installed, skipping. Package kernel-devel-3.19.3-200.fc21.x86_64 is already installed, skipping. Package kernel-devel-4.0.4-301.fc22.x86_64 is already installed, skipping. Package kernel-devel-4.0.4-303.fc22.x86_64 is already installed, skipping. Package kernel-headers-4.0.4-303.fc22.x86_64 is already installed, skipping.

Still not working.

Ujitha gravatar imageUjitha ( 2015-06-09 14:08:30 -0500 )edit

Do I have to Build kmod-wl-4.0.4-303.fc22.x86_64.x86_64 manually? how can I do it?

Ujitha gravatar imageUjitha ( 2015-06-09 14:09:44 -0500 )edit

Please Anyone help me on this.

Ujitha gravatar imageUjitha ( 2015-06-11 04:36:37 -0500 )edit

modprobe wl this was done the magic. Thank you very much baoboa your solution was worked.

Ujitha gravatar imageUjitha ( 2015-06-16 08:03:27 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-06-09 01:32:07 -0500

Seen: 1,789 times

Last updated: Jun 11 '15