Ask Your Question
0

Fedora 22 shutdown/reboot hang

asked 2015-06-08 13:38:21 -0500

gatchan gravatar image

Hi all,

After I upgrade from Fedora 21 to 22, I can't shutdown my computer by the normal way. It hang and I need to shutdown it by pressing the shutdown button a long time.

There is the journald report for my shutdown process.

Can you help me?

jun 08 20:16:41 localhost.localdomain audit[1]: <audit-1131> pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=abrtd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
jun 08 20:16:41 localhost.localdomain systemd[1]: Stopped GNOME Display Manager.
jun 08 20:16:41 localhost.localdomain audit[1]: <audit-1131> pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=gdm comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
jun 08 20:16:41 localhost.localdomain systemd[1]: Starting Show Plymouth Reboot Screen...
jun 08 20:16:41 localhost.localdomain systemd[1]: Stopping Permit User Sessions...
jun 08 20:16:41 localhost.localdomain systemd[1]: Stopping LSB: Init script for live image....
jun 08 20:16:41 localhost.localdomain systemd[1]: Stopped Permit User Sessions.
jun 08 20:16:41 localhost.localdomain systemd[1]: Stopped target Remote File Systems.
jun 08 20:16:41 localhost.localdomain systemd[1]: Stopping Remote File Systems.
jun 08 20:16:41 localhost.localdomain systemd[1]: Unmounting /mnt/music...
jun 08 20:16:41 localhost.localdomain systemd[1]: Unmounting /mnt/video...
jun 08 20:16:41 localhost.localdomain systemd[1]: Unmounting /home/muriel/docu_reseau...
jun 08 20:16:41 localhost.localdomain systemd[1]: Unmounting /mnt/documents...
jun 08 20:16:41 localhost.localdomain systemd[1]: Unmounting /mnt/photo...
jun 08 20:16:41 localhost.localdomain audit[1]: <audit-1131> pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-user-sessions comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? 
jun 08 20:16:41 localhost.localdomain kernel: cfg80211: Calling CRDA to update world regulatory domain
jun 08 20:16:41 localhost.localdomain kernel: cfg80211: World regulatory domain updated:
jun 08 20:16:41 localhost.localdomain kernel: cfg80211:  DFS Master region: unset
jun 08 20:16:41 localhost.localdomain kernel: cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
jun 08 20:16:41 localhost.localdomain kernel: cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
jun 08 20:16:41 localhost.localdomain kernel: cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
jun 08 20:16:41 localhost.localdomain kernel: cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
jun 08 20:16:41 localhost.localdomain kernel: cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
jun 08 20:16:41 localhost.localdomain kernel: cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
jun 08 20:16:41 localhost.localdomain kernel: cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
jun 08 20:16:41 localhost.localdomain kernel ...
(more)
edit retag flag offensive close merge delete

Comments

there is sometime timeout for shutting down service up to 3 min , did you wait long enough ?

look like a race condition too , with the bus shutdown before network-manager , but the log level is "info"

baoboa gravatar imagebaoboa ( 2015-06-08 15:25:09 -0500 )edit

got this too , but it's followed by NetworkManager[917]: <info> caught signal 15, shutting down normally.

baoboa gravatar imagebaoboa ( 2015-06-08 15:29:49 -0500 )edit

I got the same issue when I update from 21 to 22. It was automatically fixed after 1 day.

Ujitha gravatar imageUjitha ( 2015-06-09 01:50:35 -0500 )edit

Thanks for your help.

Unfortunately, I upgrade to F22 one or two week ago. And the bug is still there.

For the systemd "log" info. I'm not a power user with systemd. Do you have a tricks to go to debug level?

EDIT: I left my computer for 10 minutes after I shutdown it. And, I get stuck.

Thanks

gatchan gravatar imagegatchan ( 2015-06-09 11:00:15 -0500 )edit

I had too many problems with version 22 so I went to 21. Now if only I could get CUDA installed...

RogerP gravatar imageRogerP ( 2015-06-11 12:24:10 -0500 )edit

8 Answers

Sort by ยป oldest newest most voted
0

answered 2015-06-11 02:57:23 -0500

scren gravatar image

updated 2015-06-13 09:52:31 -0500

I observe the same problem in current Rawhide (last updated on June 9th), so whatever the reason is (if it is the same problem in my case) it does not seem to be fixed yet.

EDIT: The problem disappeared in my case, with package updates yesterday evening (2015-06-12). systemd and some associated packages were updated from 220-8 to 220-9, but as I also got many other updates, I don't know if it was this one, which solved the problem.

edit flag offensive delete link more

Comments

Hum... I'm still on 219 on F22.

I hope it's the solution

gatchan gravatar imagegatchan ( 2015-06-14 13:04:04 -0500 )edit
0

answered 2015-06-11 10:58:31 -0500

baoboa gravatar image

updated 2015-06-11 11:05:15 -0500

look at this web page for debugging systemd

  • at boot, in grub selection menu, edit one entry with key e
  • add this to the kernel line ( linux16 ) systemd.log_level=debug systemd.log_target=kmsg log_buf_len=1M enforcing=0
  • ctrl-x to boot
    • debug should be active for boot and shutdown
edit flag offensive delete link more
0

answered 2015-07-30 21:16:46 -0500

metg gravatar image

I observe the same problem. I think I am on latest release:

Linux asus 4.0.8-300.fc22.x86_64 #1 SMP Fri Jul 10 21:04:56 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

I have an NVIDIA card, GeForce GTX 460M. If I boot into init level 3, I can shutdown without a hitch. Once in 'init 5', neither going back to 'init 3' nor shutting down is possible.

Is there any solution to this problem?

edit flag offensive delete link more
0

answered 2015-08-27 11:30:28 -0500

croccifixio29 gravatar image

Hi baoboa. Where should I add this line. I mean in which part of the grub text at the start at the end. (linux16).

I think I have the same problem If someone have resolved please helpme.

edit flag offensive delete link more
0

answered 2016-10-22 11:59:14 -0500

donato gravatar image

I solved with a fsck, adding the following kernel parameter at boot time:

fsck.mode=force
edit flag offensive delete link more
0

answered 2016-12-30 09:51:40 -0500

This started happening to me after I disabled NetworkManager, and was fixed by running: systemctl enable NetworkManager.service

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2015-06-08 13:38:21 -0500

Seen: 8,843 times

Last updated: Oct 22 '16